UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor peter@vesper
Visitor
2,296 Views
Registered: ‎07-20-2017

Zynq 7000 on zedboard Debugging error.

Jump to solution

Hi,

 

I have Ubuntu 14.04 64bit, and trying to load code into zedboard through JTAG. While I hit this:

 

15:38:47 DEBUG	: XMD command: {"command": "xgdbserver 64 1234"}
15:38:47 DEBUG	: XMD Result: {"command":"xgdbserver 64 1234","scope":{"type":"xtarget","xtarget":{"id":64,"type":"unknown"}},"response":{"type":"success","success":{"values":["1234"],"stdout":""}}}<-
15:38:47 TRACE	: Connecting to gdbserver: localhost @ port 1234
15:38:47 TRACE	: Launching gdb..
15:38:47 ERROR	: Unexpected error while launching program.
java.lang.RuntimeException: Error creating session
	at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.debugApplication(XilinxAppLaunchConfigurationDelegate.java:806)
	at com.xilinx.sdk.debug.core.XilinxAppLaunchConfigurationDelegate.launch(XilinxAppLaunchConfigurationDelegate.java:311)
	at com.xilinx.sdk.debug.ui.XilinxAppLaunchDelegateWrapper.launch(XilinxAppLaunchDelegateWrapper.java:31)
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:885)
	at org.eclipse.debug.internal.core.LaunchConfiguration.launch(LaunchConfiguration.java:739)
	at org.eclipse.debug.internal.ui.DebugUIPlugin.buildAndLaunch(DebugUIPlugin.java:1039)
	at org.eclipse.debug.internal.ui.DebugUIPlugin$8.run(DebugUIPlugin.java:1256)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:55)

Some forum users reported that they had issue with libexpat, which I've installed and gdb is working as well:

$ ldd ./SDSoC/2016.2/SDK/2016.2/gnu/microblaze/lin/bin/mb-gdb
	linux-gate.so.1 =>  (0xf776b000)
	libncurses.so.5 => /lib/i386-linux-gnu/libncurses.so.5 (0xf7727000)
	libz.so.1 => /lib/i386-linux-gnu/libz.so.1 (0xf770d000)
	libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf76c6000)
	libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7515000)
	libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7510000)
	libtinfo.so.5 => /lib/i386-linux-gnu/libtinfo.so.5 (0xf74ee000)
	/lib/ld-linux.so.2 (0x56576000)
lrwxrwxrwx 2 root root     17 Jun 28 01:51 libexpat.so.0 -> libexpat.so.1.6.0
lrwxrwxrwx 2 root root     17 Jun 28 01:51 libexpat.so.1 -> libexpat.so.1.6.0
-rw-r--r-- 1 root root 161152 Jun 28 01:52 libexpat.so.1.6.0

 

Any ideas what might be happening. I'm using 2016.2 SDSoc. It would be very useful if the actual root cause of the error would be displayed in the console.

 

This worked previously when running it in a Virtual Machine, but I wanted a native installation. I've installed drivers as per https://www.xilinx.com/support/answers/59128.html. Which made me advance to this point, that FPGA program is good, but don't know how to proceed from here.

 

Any help would be greatly appreciated.

 

Cheers,

Peter

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
3,675 Views
Registered: ‎10-21-2010

Re: Zynq 7000 on zedboard Debugging error.

Jump to solution

Hi Peter,

There's not much detail in the log to tell what the problem is. Xilinx has deprecated GDB debug flow. System Debugger is the recommended debugger for all the debug flows. Have you tried it? You can find some details here

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
3,676 Views
Registered: ‎10-21-2010

Re: Zynq 7000 on zedboard Debugging error.

Jump to solution

Hi Peter,

There's not much detail in the log to tell what the problem is. Xilinx has deprecated GDB debug flow. System Debugger is the recommended debugger for all the debug flows. Have you tried it? You can find some details here

0 Kudos