UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor jpleiker
Visitor
2,906 Views
Registered: ‎05-26-2015

Zynq UltraScale - R5 #0 SW BSP Not Building

Jump to solution

I have am trying to generate a basic Hello World app for the R5 Core0 on the ZCU102 board; however, the BSP will not build. I get over 100 errors (most of which are make Error 127). The Build Console has the following (this is only the first few lines):

 

 

make[1]: armr5-none-eabi-gcc: Command not found
make[1]: *** [xrtcpsu_g.o] Error 127
make[1]: armr5-none-eabi-gcc: Command not found
make[1]: *** [xrtcpsu_intr.o] Error 127
make[1]: armr5-none-eabi-gcc: Command not found
make[1]: *** [xrtcpsu_selftest.o] Error 127
make[1]: armr5-none-eabi-gcc: Command not found
make[1]: *** [xrtcpsu_sinit.o] Error 127
make[1]: Target `libs' not remade because of errors.
make: *** [psu_cortexr5_0/libsrc/rtcpsu_v1_3/src/make.libs] Error 2
Running Make libs in psu_cortexr5_0/libsrc/scugic_v3_5/src
make -C psu_cortexr5_0/libsrc/scugic_v3_5/src -s libs  "SHELL=/bin/sh" "COMPILER=armr5-none-eabi-gcc" "ARCHIVER=armr5-none-eabi-ar" "COMPILER_FLAGS=  -O2 -c -mcpu=cortex-r5" "EXTRA_COMPILER_FLAGS=-g -DARMR5"
Compiling scugic
make[1]: armr5-none-eabi-gcc: Command not found
make[1]: *** [xscugic.o] Error 127

.

.

.

 

 

I've already built a Hello World app for the A56 Core0 and it ran without issue. I'm not sure why I can't build anything for the R5s. I've located the armr5-none-eabi-gcc folder within the Xilinx/SDK install directories. Is SDK not seeing this folder? Am I missing tools needed to build for the R5?

 

I'm running CentOS 6.8 x64 with the Vivado/SDK 2016.4 tools.

0 Kudos
1 Solution

Accepted Solutions
Visitor jpleiker
Visitor
5,174 Views
Registered: ‎05-26-2015

Re: Zynq UltraScale - R5 #0 SW BSP Not Building

Jump to solution

When trying to run the binary I received an error "/lib/ld-linux.so.2: bad ELF interpreter: No such file or directory". With some Googling I found that this meant I did not have 32-bit library support installed on my CentOS 64-bit machine. Once I ran a ' yum groupinstall "Compatibility libraries" ' I could rebuild the R5 project without issue.

 

Thanks!

0 Kudos
3 Replies
Visitor jpleiker
Visitor
2,826 Views
Registered: ‎05-26-2015

Re: Zynq UltraScale - R5 #0 SW BSP Not Building

Jump to solution

Some more information on how I got to this point:

 

1) Dropped Zynq US+ IP in to block diagram (ran block automation and disabled the M_AXI ports)

2) Created HDL wrapper, generated bitstream, exported hardware to SDK

3) Opened SDK local to the project so that the hardware I just created was targetted

4) Created new application on a standalone OS, targeting my hw platform, processor is the psu_corexr5_0

5) Let it create a new BSP, select Hello World app, and Build

 

 

I can repeat those exact steps with the exception of selecting the A56 core0 instead and it builds just fine. My best guess based on what Googling the errors tells me is that it's most likely a compiler/gcc problem. However, if I right click the project and go to C/C++ Build -> Tool Chain Editor I'm using the correct R5 toolchain. I'm not sure what I need to do to get this to build.

0 Kudos
Xilinx Employee
Xilinx Employee
2,812 Views
Registered: ‎10-21-2010

Re: Zynq UltraScale - R5 #0 SW BSP Not Building

Jump to solution

Hi,

The problem could either be because r5 toolchain is not installed with your SDK (it's optional while installing SDK), or your PATH is not setup correctly to pick the r5 toolchain.

 

Since you see armr5-none-eabi-gcc directory in SDK install, can you verify if you're able to run armr5-none-eabi-gcc binary from a terminal? It's located at $XILINX_SDK/gnu/armr5/lin/gcc-arm-none-eabi/bin/armr5-none-eabi-gcc

 

If this works, then check if your PATH env variable includes $XILINX_SDK/gnu/armr5/lin/gcc-arm-none-eabi/bin. If PATH doesn't include this location, update it in the terminal, before you launch SDK

0 Kudos
Visitor jpleiker
Visitor
5,175 Views
Registered: ‎05-26-2015

Re: Zynq UltraScale - R5 #0 SW BSP Not Building

Jump to solution

When trying to run the binary I received an error "/lib/ld-linux.so.2: bad ELF interpreter: No such file or directory". With some Googling I found that this meant I did not have 32-bit library support installed on my CentOS 64-bit machine. Once I ran a ' yum groupinstall "Compatibility libraries" ' I could rebuild the R5 project without issue.

 

Thanks!

0 Kudos