cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
917 Views
Registered: ‎02-12-2018

cannot launch XSDK from vivado

Version: Vivado 2017.4

OS: Ubuntu 16.04

 

hello,

 

from within Vivado, "Launch SDK" does not work. TCL console provides the following:

 

launch_sdk -workspace /home/user/xilinx.sdk -hwspec /home/user/xilinx.sdk/xilinx.hdf
INFO: [Vivado 12-393] Launching SDK...
INFO: [Vivado 12-417] Running xsdk -workspace /home/user/xilinx.sdk -hwspec /home/user/xilinx.sdk/xilinx.hdf
INFO: [Vivado 12-3157] SDK launch initiated. Please check console for any further messages.

 

and SDK.log has no output. XSDK attempts to launch (startup logo appears) but workspace does not load. No error message is displayed. I launched the workspace from comandline, no error message is displayed either.

 

Apparently my workspace got corrupted.

 

- temporarily loading a new workspace, then switching to the old one (the new one loads, though)

- deleting .SDK/

- deleting /home/user/.Xilinx/SDK/2017.4/

 

 

What can I do to recover from this?

Tags (1)
0 Kudos
1 Reply
Highlighted
Moderator
Moderator
855 Views
Registered: ‎02-09-2017

Hi @theultimatesource,

 

I once had an issue like that, and what solved the issue for me was going into the project directory and completely delete the <project_name>.sdk folder.

 

Then in Vivado, go and select the option Export HW again and then try to launch SDK again.

 

project.sdk folder.JPG

 

Please let us know if that helps.

 

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos