cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
275 Views
Registered: ‎11-18-2019

fsbl_printf doesn't work

Jump to solution

I added "#define FSBL_DEBUG_INFO 1" before "#define DEBUG_GENERAL 0x00000001" in fsbl_debug.h, but it didn't work.

Also, I tried using "init_platform();" in platform.h, but it didn't work.

By the way, it is qspi boot.

1 Solution

Accepted Solutions
Moderator
Moderator
235 Views
Registered: ‎09-12-2007

right click on the app, and choose C/C++ build settings, then in the symbols add the FSBL_DEBUG_INFO. Clean, and rebuild. You can test in jtag (download the FSBL and execute, and make sure the debug prints are there)

 

Once verified, You will have to rebuild your boot image again.

View solution in original post

2 Replies
Moderator
Moderator
236 Views
Registered: ‎09-12-2007

right click on the app, and choose C/C++ build settings, then in the symbols add the FSBL_DEBUG_INFO. Clean, and rebuild. You can test in jtag (download the FSBL and execute, and make sure the debug prints are there)

 

Once verified, You will have to rebuild your boot image again.

View solution in original post

Observer
Observer
208 Views
Registered: ‎11-18-2019

Thank you, it worked !