UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor fatimajoon
Visitor
6,769 Views
Registered: ‎09-10-2007

hi, I wanted to simulate an ipcore with xps. I compiled...

hi,

I wanted to simulate an ipcore with xps.
I compiled the simulation libraries,
then I generated simulation HDL files.

but when I select the launch HDL simulator
I enconter the following:

make: nothing to be done for "simmodel'

best regards
0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
6,734 Views
Registered: ‎08-07-2007

Re: hi, I wanted to simulate an ipcore with xps. I compiled...

XPS is makefile based.  That means that it should only run a compiler, or generate netlists if something has changed since the last time you ran a command.
 
It looks like you have previously run the simulation generator (simgen) to generate the simulation models for your system.
 
Launch HDL simulator should launch your simulation tool (ie Modelsim, Ncsim).
 
It would be worth checking that the executable for your simulator is in your path.  Check /doc/usenglish/help/platform_studio/html/ps_p_sim_setting_up_modelsim_for_using_smartmodels.htm or /doc/usenglish/help/platform_studio/html/ps_p_sim_setting_up_ncsim_for_using_smartmodels.htm to see if that helps.
 
Kris Chaplin
Xilinx UK
0 Kudos