cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Participant
Participant
333 Views
Registered: ‎01-13-2019

how to establish serial communication in vitis for ZCU111

Jump to solution

I'm following the Hello World example in UG1209 with ZCU111 dev kit.

Board boot mode is set to JTAG, and one micro-USB cable (since only 1 microUSB port is available on the board) is used to connect from J83 on the board to workstation.

Host OS is RHEL 7.6.

Tried with /dev/ttyUSB[0123] and /dev/ttyS[0123], but none of them working.

All report "No such port".

Could anyone help with this issue?

Thanks a lot.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Participant
Participant
308 Views
Registered: ‎01-13-2019

The following solution should be able to enable the serial port on RHEL.

https://access.redhat.com/articles/7212 

 

According to above link, for RHEL 7.x:

Serial Terminal Configuration in RHEL 7
Add, or update if already present, the following lines to /etc/default/grub:

Raw
GRUB_CMDLINE_LINUX_DEFAULT="console=tty0 console=ttyS0,115200"
GRUB_TERMINAL="console serial"
GRUB_SERIAL_COMMAND="serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1"
GRUB_CMDLINE_LINUX_DEFAULT applies this configuration only to the default menu entry, use GRUB_CMDLINE_LINUX to apply it to all the menu entries.
NOTE: each line type above should only appear once within the /etc/default/grub file. If the line already exists, then just modify it rather than add a second copy of same. That is, only one GRUB_CMDLINE_LINUX_DEFAULT line should exist in the file, etc.
Rebuild the /boot/grub2/grub.cfg file by running the grub2-mkconfig -o command as follows:

On BIOS-based machines: ~]# grub2-mkconfig -o /boot/grub2/grub.cfg
On UEFI-based machines: ~]# grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg
Additional information available in RHEL 7 System Administrator's Guide 25.9. GRUB 2 over a Serial Console

 Hope this help.

View solution in original post

3 Replies
Highlighted
Participant
Participant
309 Views
Registered: ‎01-13-2019

The following solution should be able to enable the serial port on RHEL.

https://access.redhat.com/articles/7212 

 

According to above link, for RHEL 7.x:

Serial Terminal Configuration in RHEL 7
Add, or update if already present, the following lines to /etc/default/grub:

Raw
GRUB_CMDLINE_LINUX_DEFAULT="console=tty0 console=ttyS0,115200"
GRUB_TERMINAL="console serial"
GRUB_SERIAL_COMMAND="serial --speed=115200 --unit=0 --word=8 --parity=no --stop=1"
GRUB_CMDLINE_LINUX_DEFAULT applies this configuration only to the default menu entry, use GRUB_CMDLINE_LINUX to apply it to all the menu entries.
NOTE: each line type above should only appear once within the /etc/default/grub file. If the line already exists, then just modify it rather than add a second copy of same. That is, only one GRUB_CMDLINE_LINUX_DEFAULT line should exist in the file, etc.
Rebuild the /boot/grub2/grub.cfg file by running the grub2-mkconfig -o command as follows:

On BIOS-based machines: ~]# grub2-mkconfig -o /boot/grub2/grub.cfg
On UEFI-based machines: ~]# grub2-mkconfig -o /boot/efi/EFI/redhat/grub.cfg
Additional information available in RHEL 7 System Administrator's Guide 25.9. GRUB 2 over a Serial Console

 Hope this help.

View solution in original post

Highlighted
Xilinx Employee
Xilinx Employee
302 Views
Registered: ‎02-12-2020

Hi @liuyz ,

Can you try the following steps:

1.  su root  // switch to a root user.

2.. chmod 777 /dev/ttyUSB1   // This should be your serial port

3.  in the sdk/terminal make a new connection:  /dev/ttyUSB1

An alternative to this you could use Teraterm or Putty. You can also refer to this wiki for further details.

 
Please let me know if you still need more assistance.
Thanks,
R.Samhoud
------------------------------------------------------------------------------
Don't forget to reply, give Kudo and accept as solution
------------------------------------------------------------------------------
0 Kudos
Highlighted
Participant
Participant
224 Views
Registered: ‎01-13-2019

Hi @romisaas ,

Thanks for the extra info.

I actually add my user to the dialout group before following the RHEL procedures. However, this was not good.

I will give your procedures a try when I setup a 2nd workstation.

Thanks a lot.