Showing results for 
Show  only  | Search instead for 
Did you mean: 
Registered: ‎09-20-2018

how to recover from Invalid DAP ACK value: 0 on linux?

I am running tcl commands from xsct in non-interactive mode.

The script fails, causing the board to enter an error state:

Invalid DAP ACK.png

1. I enter this state when running the script in xsct. I am receiving the same error when using XSDK -> run as -> launch application

2. Afterwards, I power cycled the board, closed all consoles and XSDK, the error remains

3. I can recover from this state rebooting the host OS


How can I recover from this state? I presume there is some process running that I can kill?


thank you

Invalid DAP ACK.png
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
Registered: ‎10-06-2016

Hi @jack.roundhouse

It seems strange the fact that you need to reboot the host to recover from the issue :O

Could you give bit more details about your use case in terms of which device are you using, the kind of script you are using... I mean is the XSCT script accessing to the reported memory address? is the application doing that?


Don’t forget to reply, kudo, and accept as solution.
0 Kudos
Registered: ‎09-20-2018

XSDK is accessing the reported memory address.

1. I was causing a DAP ACK event with the script I created (xsct, non-interactive). The script was clearing the FPGA configuration before programming the ARM processor, but the setup was missing several modifications for proper operation.

2. After this I switched to XSDK.

3. I was able to burn the FPGA but unable to program the processor.

4. In this state, after rebooting the host OS, launching XSDK and burning the FPGA I was able to run same application with no errors.

5. These steps could be repeated when using the script to cause a DAP ACK.

# hw setup

- OS: Ubuntu 16.04
- board: Zybo
- device: Zynq 7010

# sw setup:
- XSDK 2017.4

The run configurations I used had "Run ps7_init" and "Run ps7_post_config" set. The application used was the default hello world for C.

# further details

Without rebooting, what I tried without success to recover was

- power cycling the board

- reconnect the USB programming port

- closing all applications, there where no shell commands, xsdk or xsct processes listed in the system monitor.

- restarting XSDK.

The minimum steps I used to recover were

- rebooting host OS
- reset entire system


Unfortunately I don't have the original script anymore. Today I induced a DAP ACK but have been unable to replicate the steps described above. When I have more findings I can report them here.

0 Kudos