cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
3,486 Views
Registered: ‎05-15-2014

hw_server connection to second FPGA in chain

I try to establish a connection using hw_serve, however there I a problem:

My Jtag chain includes 4 devices:

 - FPGA0 12aec093 irlen 10

 - FPGA1 1a6e7069 irlen 10 <MB system here

 - cypress  irlen 3

 - ti irlen 8

 

The Multicode (2 cpus) Microblaze system is on FPGA1 (not FPGA0)

 

When connecting with xmd I use "-debugdevice devicenr 2" to select FPGA1.

 

However when starting hw_server I cannot specify which device to use: It seems

that hw_server tries to connect to device 1 (FPDA0) and therefore I get the error message that

MDM is not found.

I tried to specify the special JTAG chain in Xiinx Tools->Configure Jtag Settings

"Manual Configuration of JTAG Chain", where I check FPGA1 as the debug device

however the hw_server connection doesnt seem to use this part of the dialog.

 

Is there a posibility to tell hw_server to use "-debugdevice devicenr 2" ?

 

Greetings Konrad

0 Kudos
4 Replies
Highlighted
Xilinx Employee
Xilinx Employee
3,456 Views
Registered: ‎04-16-2012

Re: hw_server connection to second FPGA in chain

Hi Konrad,

 

Use the following Tcl command to program the first device in the JTAG chain.

 

program_hw_devices [lindex [get_hw_devices] 0]

 

For programming second device in the JTAG chain, use the below Tcl command:

 

program_hw_devices [lindex [get_hw_devices] 1]

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Visitor
Visitor
3,444 Views
Registered: ‎05-15-2014

Re: hw_server connection to second FPGA in chain

Hi Vinay,

I try to start the hw_server.exe in a cmd.com console. There is

no tcl command prompt. I dont want to program a device but

connect from the SDK using the system debugger...

-- Greetings Konrad

0 Kudos
Highlighted
Anonymous
Not applicable
3,439 Views

Re: hw_server connection to second FPGA in chain

0 Kudos
Highlighted
Visitor
Visitor
3,385 Views
Registered: ‎05-15-2014

Re: hw_server connection to second FPGA in chain

Sorry, doesnt seem o be related to my problem.

Back to printf debugging :-)

0 Kudos