UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor mellotanica
Visitor
7,124 Views
Registered: ‎03-01-2017

linux xilinx xsdk stopped working

Jump to solution

hello everyone, i used the xsdk both from command line and ide for a few months without trouble, but last week it decided to let me down.. each time i run the xsct command line tool it prints out this error end exits:

package require hsi FAILED:
invalid command name "hsi::create_dt_node"
    while executing
"hsi::create_dt_node -help"
    (in namespace eval "::hsi::help" script line 6)
    invoked from within
"namespace eval ::hsi::help {
    variable version 0.1

    ::xsdb::setcmdmeta {hsi create_dt_node} categories {hsi}
    ::xsdb::setcmdmeta {hsi create..."
    (file "/opt/Xilinx/SDK/2016.4/scripts/xsdb/hsi/hsihelp.tcl" line 1)
    invoked from within
"source /opt/Xilinx/SDK/2016.4/scripts/xsdb/hsi/hsihelp.tcl"
    ("package ifneeded hsi::help 0.1" script)

and the ide hangs on the initializing s/w repositories phase (same as this thread, also returning the same error after some minutes).

 

i already tried pretty much anything that came to my mind: i reinstalled the sdk several times downloading and checking the installer checksum, i tried launching both tools from different shells sourcing explicitly the settings64.sh file and using relative and absolute paths, i cleaned workspaces and configurations in home directory and tried changing the rdiArgs.sh script to use the system java binary instead of the portable one shipped with the sdk.

 

now i'm out of ideas and i'm wondering if there may be some solutions that i didn't consider.

 

my system configuration is as follows:

arch linux with 4.9.11 kernel running on an intel core i7 870 processor with 6G of memory
the system installed java version is openjdk 1.8.0_121

the xilinx xsdk version is 2016.4 with java 1.8.0_66

 

thanks

0 Kudos
1 Solution

Accepted Solutions
Visitor mellotanica
Visitor
12,059 Views
Registered: ‎03-01-2017

Re: linux xilinx xsdk stopped working

Jump to solution

yes, i failed at copypasting.. i have both librdi_hsm.so and librdi_hsmtasks.so

 

i'm not able to run sdk from the backup, but i ran bin/hsi and it gave me some sort of intresting error:

application-specific initialization failed: couldn't load file "librdi_commontasks.so": libncurses.so.5: cannot open shared object file: No such file or directory

 

and it was the cause! it seems like arch recently passed to ncurses 6, this broke a dependency and i fixed it by installing the ncurses5-compat-libs compatibility libraries from the aur

 

thank you a lot!

 

10 Replies
Xilinx Employee
Xilinx Employee
7,105 Views
Registered: ‎10-21-2014

Re: linux xilinx xsdk stopped working

Jump to solution

Can you try setting the environment variable XILINX_SDK to  /opt/Xilinx/SDK/2016.4 and launch xsdk.

0 Kudos
Visitor mellotanica
Visitor
7,087 Views
Registered: ‎03-01-2017

Re: linux xilinx xsdk stopped working

Jump to solution

didn't work.. the ide hangs on initializing s/w repositories like before, i also noticed that in the "sdk log" panel inside the ide is shown this error:

 

14:32:21 ERROR	: (XSDB Server)package require hsi FAILED:
invalid command name "hsi::create_dt_node"
    while executing
"hsi::create_dt_node -help"
    (in namespace eval "::hsi::help" script line 6)
    invoked from within
"namespace eval ::hsi::help {
    variable version 0.1

    ::xsdb::setcmdmeta {hsi create_dt_node} categories {hsi}
    ::xsdb::setcmdmeta {hsi create..."
    (file "/opt/Xilinx/SDK/2016.4/scripts/xsdb/hsi/hsihelp.tcl" line 1)
    invoked from within
"source /opt/Xilinx/SDK/2016.4/scripts/xsdb/hsi/hsihelp.tcl"
    ("package ifneeded hsi::help 0.1" script)
14:35:21 ERROR	: Timed out. 180 seconds have elapsed while waiting for XSCT server to launch.
14:35:21 INFO	: Launching XSCT server: xsct -n -interactive /home/mello/workspace/temp_xsdb_launch_script.tcl
14:35:21 ERROR	: (XSDB Server)package require hsi FAILED:
invalid command name "hsi::create_dt_node"
    while executing
"hsi::create_dt_node -help"
    (in namespace eval "::hsi::help" script line 6)
    invoked from within
"namespace eval ::hsi::help {
    variable version 0.1

    ::xsdb::setcmdmeta {hsi create_dt_node} categories {hsi}
    ::xsdb::setcmdmeta {hsi create..."
    (file "/opt/Xilinx/SDK/2016.4/scripts/xsdb/hsi/hsihelp.tcl" line 1)
    invoked from within
"source /opt/Xilinx/SDK/2016.4/scripts/xsdb/hsi/hsihelp.tcl"
    ("package ifneeded hsi::help 0.1" script)
14:38:21 ERROR	: Timed out. 180 seconds have elapsed while waiting for XSCT server to launch.
14:38:21 ERROR	: Failed to call init_repo
Reason: xsct server communication channel is not established.
14:38:21 ERROR	: Exception raised in executing the command =Failed to call init_repo
Reason: xsct server communication channel is not established. 
0 Kudos
Visitor mellotanica
Visitor
7,085 Views
Registered: ‎03-01-2017

Re: linux xilinx xsdk stopped working

Jump to solution

one thing i forgot to mention is that after the error on initializing software repositories the ide won't let me close it, throwing out the following error and going back to main screen:

 

An error has occurred. See error log for more details.
Could not initialize class com.xilinx.sdk.sw.SwDbUtils$SwReposManHolder

 

i need to kill the java process to close the ide..

0 Kudos
Xilinx Employee
Xilinx Employee
7,071 Views
Registered: ‎10-21-2010

Re: linux xilinx xsdk stopped working

Jump to solution

Hi,

It looks like some libraries/scripts are missing from SDK installation. Can you check if you're able to run $XILINX_SDK/bin/hsi and also if $XILINX_SDK/lib/lnx64.o/librdi_hsm* libraries exist

0 Kudos
Visitor mellotanica
Visitor
7,065 Views
Registered: ‎03-01-2017

Re: linux xilinx xsdk stopped working

Jump to solution

ok, i can't find any hsi executable/script inside the bin directory, but in lib/lnx64.o/ i have librdi_hsm.so and librdi_hsm.so.

 

i don't understand why the hsi script is missing (i have a backup of the 2016.3 installation and the script is present)

0 Kudos
Xilinx Employee
Xilinx Employee
7,059 Views
Registered: ‎10-21-2010

Re: linux xilinx xsdk stopped working

Jump to solution

Are you able to run SDK from your back up installation? Also, do you mean you have librdi_hsm.so and hsmtasks.so in lib/lnx64.o

0 Kudos
Visitor mellotanica
Visitor
12,060 Views
Registered: ‎03-01-2017

Re: linux xilinx xsdk stopped working

Jump to solution

yes, i failed at copypasting.. i have both librdi_hsm.so and librdi_hsmtasks.so

 

i'm not able to run sdk from the backup, but i ran bin/hsi and it gave me some sort of intresting error:

application-specific initialization failed: couldn't load file "librdi_commontasks.so": libncurses.so.5: cannot open shared object file: No such file or directory

 

and it was the cause! it seems like arch recently passed to ncurses 6, this broke a dependency and i fixed it by installing the ncurses5-compat-libs compatibility libraries from the aur

 

thank you a lot!

 

Highlighted
Visitor balbir1430
Visitor
2,951 Views
Registered: ‎06-03-2018

Re: linux xilinx xsdk stopped working

Jump to solution

I am facing the same error and followed this thread. Everything seems to work fine.

I ran /bin/hsi and it worked fine.

But I am still facing the same error "Could not initialize class com.xilinx.sdk.sw.SwDbUtils$SwReposManHolder" on running SDK from the terminal.

I am using 64-bits ubuntu 16.04, Vivado 2016.4, SDK 2016.4.

Please help.

 

0 Kudos
Adventurer
Adventurer
1,232 Views
Registered: ‎01-24-2018

Re: linux xilinx xsdk stopped working

Jump to solution

I have the same problem.

Ubuntu 16.04, SDK 2017.3.

It has done this before, but killing all of the SDK instances usually fixed it.

It has ran just fine for weeks and just decided to fail again this morning.

I cannot figure out how to untie the knot that it has tied itself into.

There has been no software changes to the host system on which it is installed.

The Xilinx SDK just does this every once in awhile as far as I can tell.

One day it runs okay, the next day it is not... for no real apparent reason.

0 Kudos
Visitor kotz7
Visitor
106 Views
Registered: ‎12-12-2018

Re: linux xilinx xsdk stopped working

Jump to solution

can you please share any links or command to download those packages.

0 Kudos