UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
8,773 Views
Registered: ‎01-22-2015

-lrsa cannot found while creating FSBL Application in SDK 14.7

 

Hi All,

           I am trying to create fsbl for zynq AMP in sdk 14.7 but facing the problem which is given below.

 

c:/xilinx/14.7/ise_ds/edk/gnu/arm/nt/bin/../lib/gcc/arm-xilinx-eabi/4.7.3/../../../../arm-xilinx-eabi/bin/ld.exe: cannot find -lrsa
collect2.exe: error: ld returned 1 exit status
make: *** [amp_fsbl.elf] Error 1

 

 

I searched previous answer records and i found the same problem query for sdk14.5. And then i followed the answer steps but still i coulnt able to solve the issue. Please help me to solve this problem.

 

i tried with following links which is given below

http://www.xilinx.com/support/answers/55581.html

 

 

Thanks,

Ramesh

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
8,761 Views
Registered: ‎07-01-2010

Re: -lrsa cannot found while creating FSBL Application in SDK 14.7

@ramesh.d2015

 

 

A similar issue is discussed in the thread http://forums.xilinx.com/t5/Embedded-Development-Tools/SDK-ld-exe-cannot-find-lrsa/td-p/330545

 

Refer to the "ljump@drs.com"post which might fix the issue for you.

 

Please update us on the fix so that we can try updating the solution.

 

Regards,

Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
8,751 Views
Registered: ‎01-22-2015

Re: -lrsa cannot found while creating FSBL Application in SDK 14.7

Hi Achutha,

                     I refered that post already  which you have given now,

In that post,

Xilinx has updated the design files:

http://www.wiki.xilinx.com/XAPP1078+Latest+Information

http://www.wiki.xilinx.com/XAPP1079+Latest+Information

 

these links contains the design files of EDK & SDK versions 14.5 and 14.6, but i am using 14.7.

With these design files i am trying to create the fsbl for zynq AMP in 14.7 version but i am getting error.

Also they discussed the solution from this link http://www.xilinx.com/support/answers/55581.htm. I tried with this also but it not working for me.

 

 

Thanks,

Ramesh

0 Kudos
Xilinx Employee
Xilinx Employee
8,727 Views
Registered: ‎08-02-2007

Re: -lrsa cannot found while creating FSBL Application in SDK 14.7

hi,

 

RSA support was only added in 14.5.check if your FSBL is based off Standalone BSP v3.7

 

To create a FSBL without error, you can remove the rsa option in C/C++ propoerties and change BSP version to the latest.

 

--hem

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
8,690 Views
Registered: ‎01-22-2015

Re: -lrsa cannot found while creating FSBL Application in SDK 14.7

Hi Hem,

 

              Actually i have the design files of AMP example design on zynq zc702. It contains fsbl,boot.bin etc and directly i implemented it on board and its working properly. But i wanted to create all the files from the scratch, i have created u-bbot.elf,kernel,filesystem ( they explained in the doc how do these things). And then while creating fsbl i am facing this issue and i reffered all the links and answer records but i couldn't solve it. Also i tried with what you explained.

 

If i remove or add the -lrsa from C/C++ settings also i am getting the same error and i do not know how they created the BSP for this example design but still i tried that also. Now i do not know what to do and how to solve this problem.

 

the ref design files are in this link,

http://www.wiki.xilinx.com/XAPP1079+Latest+Information

 

 

 

Thanks,

Ramesh

0 Kudos