UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie ovimaya
Newbie
3,246 Views
Registered: ‎01-29-2009

problems using chipscope

Hello,

I'm doing the ChipScope & Embedded Processor Lab to learn how to use the ChipScope in a XPS project. I went to Debug->Debug Configuration.... in order to add a chipscope to the project.
I took the folows options:

1)Click the Add Chipscope Peripheral... button
2)Selected the first option, To monitor OPB bus signals (adding OPB IBA)
3)Click to put a check mark in the Enable Hardware/Software Co-debug field

With that I creteted two peripherals named chipscope_icon_0 and chipscope_plbv46_iba_0.

Then I want to generate the Netlist but there are errors. The XPS Output says

Running DRC Tcl procedures for OPTION SYSLEVEL_DRC_PROC...

Check platform configuration ...
IPNAME:plb_v46 INSTANCE:mb_plb - C:\EDKprojects\EDK-Labs\LAB6-2\system.mhs line
48 - 2 master(s) : 9 slave(s)
make: *** [implementation/microblaze_0_wrapper.ngc] Error 2
IPNAME:lmb_v10 INSTANCE:ilmb - C:\EDKprojects\EDK-Labs\LAB6-2\system.mhs line 55
- 1 master(s) : 1 slave(s)
IPNAME:lmb_v10 INSTANCE:dlmb - C:\EDKprojects\EDK-Labs\LAB6-2\system.mhs line 62
- 1 master(s) : 1 slave(s)
ERROR:MDT - IPNAME:mdm INSTANCE:debug_module BUS_INTERFACE:SPLB -
C:\EDKprojects\EDK-Labs\LAB6-2\system.mhs line 137 - invalid bus interface in
use when ISVALID="((C_INTERCONNECT == 1) && (C_USE_UART == 1))" evaluates to
FALSE. Please remove the bus interface from your design!
ERROR:MDT - platgen failed with errors!
Done!


What can I do to fix the problem?

I'm using the 10.1 version with the last update.

Thanks

0 Kudos
1 Reply
Contributor
Contributor
2,496 Views
Registered: ‎06-12-2008

Re: problems using chipscope

Hello,

 

you can get past the error by setting the C_USE_UART = 1 for the mdm module. Either edit the .mhs file directly or right click the mdm/ debug module in XPS and select "configure IP..." and check "Enable  JTAG UART".

 

I don't know if doing this it will cause any other problems later...

 

HTH

 

--

Magne

0 Kudos