cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
moh_13
Observer
Observer
4,013 Views
Registered: ‎05-30-2017

sdk 2017 errors

hello everyone,i start a project in order to create a standard memory test project with SDK;so i began with creating a Vivado project for a Zynq system then  Using the IP Integrator to create a hardware system.

Arriving to the step of exporting the design to SDK,when i select File > New > Application Project, i obtain this errors : 

 

Timed out. 180 seconds have elapsed while waiting for XSCT server to launch.

Failed to openhw "C:/**********/system.hdf" Reason: xsct server communication channel is not established

 

and the ide hangs on the initializing s/w repositories phase is returning an error message after some minutes.

Also i can't even open the system.hdf file (Hardware Description File) for the Hardware platform.

 

I'm out of ideas because i'm a new learner so i'm asking your help.Thank's.

 

my system configuration is as follows: windows10 64bits

the system installed java version is build 1.8.0_111

the xilinx sdk version is Xilinx Software Development Kit Release Version: 2017.1

0 Kudos
9 Replies
stephenm
Xilinx Employee
Xilinx Employee
3,978 Views
Registered: ‎09-12-2007

Is the SDK installed on your local machine, or from a network drive?

Can you open the xsct command line from SDK and use the command openhw system.hdf

Do you see the same here?

You can also increase the sdk_launch_timeout in scripts/xsdb/xsdb/xsdb.tcl in your SDK install
0 Kudos
moh_13
Observer
Observer
3,962 Views
Registered: ‎05-30-2017

thank's for your response

yeah SDK is installed in my machine and after writing openhw system.hdf command,the XCST console displays the following message:
ERROR: Could not find 64-bit executable.
ERROR: C:/Xilinx/SDK/2017.1/bin/unwrapped/win64.o/rdi_xsct.exe does not exist

it seems that it is a missing file;i download the windows 64 bits version from there

should i reinstall the version?

 

0 Kudos
ibaie
Xilinx Employee
Xilinx Employee
3,952 Views
Registered: ‎10-06-2016

Hi @moh_13

 

Definitively that binary file should be in your installation directory. Did you check that? If it is not there, just try to reinstall it.

Capture.JPG


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
moh_13
Observer
Observer
3,949 Views
Registered: ‎05-30-2017

no i haven't it 

can you please send it this executable file because i reinstall vivado and i still haven't this file.

0 Kudos
ibaie
Xilinx Employee
Xilinx Employee
3,945 Views
Registered: ‎10-06-2016

Hi @moh_13,

 

Did you reinstall also the SDK? Try to first uninstall vivado/sdk and once you verified that everything has been removed just install it. I don't think that sending this executable will solve your issues as if this file is missing probably there will be more too ;)


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
moh_13
Observer
Observer
3,933 Views
Registered: ‎05-30-2017

hi 

4.png

0 Kudos
ibaie
Xilinx Employee
Xilinx Employee
3,931 Views
Registered: ‎10-06-2016

Hi @moh_13

 

Did you try to launch the exe file from the file browser rather than from the link?? I never saw this issue but you should check the host requirements within the Vivado documentation.


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos
moh_13
Observer
Observer
3,821 Views
Registered: ‎05-30-2017

hi dear,

it seems like vivado 2017 is not yet compatible with windows 10 or my machine is in such a mess.

because i install it on win7.1 and i can start sdk from vivado without error message.

Thank's

0 Kudos
ibaie
Xilinx Employee
Xilinx Employee
3,800 Views
Registered: ‎10-06-2016

Hi @moh_13

 

Vivado tool suite (including the SDK) should work on Win10, so probably there is some missing or not default mode dependencies that are making the tool not work as expected.


Ibai
Don’t forget to reply, kudo, and accept as solution.
0 Kudos