cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mthendricks
Observer
Observer
7,071 Views
Registered: ‎09-30-2009

sdk debugger: suspend button greyed out

I have started debugging a project running on the microblaze.using the SDK.  When I initiate a debug session, the GUI gives me run/resume button, but the suspend (pause) button in greyed out.  Once I start a run, I'm only given the option of terminating the debug session. All other debug buttons (and menu items) are grayed out. I can't pause it and look at variables etc. What must I do to have an active suspend button?

 

As an aside, at the bottom of the Debug perspective, I can click the XMD tab.  From this tab I can type "stop" and "con" to do this.  Why won't the GUI give me the same functionality?

 

System:

Spartan 3a-DSP 1800 eval board

EDK/SDK: 10.1

OS:  ThreadX

0 Kudos
9 Replies
purplebox
Newbie
Newbie
6,678 Views
Registered: ‎11-28-2010

I have exactly the same issue using version 12.3 on a 64-bit Windows 7 machine.

 

Does anybody know what the issue is and how to fix it?

 

Thanks,

 

David.

0 Kudos
mthendricks
Observer
Observer
6,639 Views
Registered: ‎09-30-2009

I am using version 11.5 of the SDK, and when I click the "run" button, the pause button is always greyed out.  What you have to do is, after clicking "run,"  select your thread in the debug window.  In my case there is as thread called "Thread[0](Running)" in the Debug window in the upper left of the SDK.  When I click this, the pause button magically regains its color and can be used.

 

 

0 Kudos
butowski
Visitor
Visitor
6,527 Views
Registered: ‎02-10-2011

I have the same problem under 12.4 and Windows 7 x64.  The button is grayed out however i can type stop into XMD Console to interrupt the processor.

0 Kudos
jjurack
Visitor
Visitor
6,342 Views
Registered: ‎04-15-2011

I am having the same issue, again on 64-bit Windows 7, with version 13.1. XMD stop works for me, but clicking on "Thread [0]" doesn't work.

0 Kudos
vsiva
Xilinx Employee
Xilinx Employee
6,339 Views
Registered: ‎01-18-2008

Only applies to 13.x on Win64: http://www.xilinx.com/support/answers/41225.htm

0 Kudos
jjurack
Visitor
Visitor
6,329 Views
Registered: ‎04-15-2011

Thanks, that works great! One thing, though: you linked the wrong attachment -- that's the patch, not the zip file.

0 Kudos
4,305 Views
Registered: ‎09-02-2014

Hello,

I've tried the link to get the answer, but it points to no answer-record.

 

0 Kudos
drbyte
Observer
Observer
1,800 Views
Registered: ‎03-07-2011

Hello,

same problem with VIVADO 2016.1 and Win10 x64 machine.

 

I can run the debug (GDB) and use the step mode (step into and step over) but when I choose to resume I'm unable to stop the debug and the only option is the red button (Terminate CTRL+F2).

 

img1.jpg

 

Could you please let me know how to overcome this problem?

 

Thanks

 

0 Kudos
drbyte
Observer
Observer
1,759 Views
Registered: ‎03-07-2011

Just an update I'm able to solve the issue by a BSP rebuilding.

 

Best regards

0 Kudos