We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Showing results for 
Search instead for 
Did you mean: 
Visitor mkray
Registered: ‎03-27-2018

system debugger stalls at launch when debugging linux application over ethernet on zc706

I have dropbear ssh and tcf-agent starting at bootup on the zc706 board via sd boot. After logging in, I assign inet addr and netmask values to eth0 using ifconfig. I am able to ping the zc706 board from the Windows command prompt successfully but I can not ping the host machine from the zc706 board.


In the XSDK "Debug Configurations.." for the System Debugger option, I choose "Linux Application Debug" and press the "New" button to specify a Target Name, Host, and port (1534) and I press "Test Connection" which is successful. Then on the application tab, I enter the information as specified in UG1165 for Project Name, Local File Path, and Remote File Path and then I hit "Apply". Next I hit "Debug".

I'm taken to the Debug perspective where I see a progress bar with the text "Launching System Debugger on Local hello_world.elf" on top of the bar and another text "Launching: Connecting to hello_linux". The progress bar is stuck here at 57% and I have no idea why. I've already tried a number of different things and just can't get past this point.

Any help would be greatly appreciated.



0 Kudos
1 Reply
Visitor mkray
Registered: ‎03-27-2018

Re: system debugger stalls at launch when debugging linux application over ethernet on zc706

I solved the problem. I was using a version of Xilinx SDK that didn't support debugging via TCF agent. I had to use the Remote Arm Linux Application under Debug Configurations. I was having this problem in the first place because the version of UG1165 I was reading was newer than the version of Xilinx SDK that I was using.



0 Kudos