UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

undefined inclusion and can't find include

Highlighted
Visitor
Posts: 5
Registered: ‎09-06-2017

undefined inclusion and can't find include

Hello, I've been working with ZYBO board and started working with SDK, before that I've only used it to run the PL clocks, so it was just an empty main and I had no problem. First I wanted to try the audio demo, but I got many errors saying that certain .h includes couldn't be found, I looked for them and they were in one of the directories specified in the Paths and Symbols of the project. Then I tried the FreeRTOS and got the same type of errors, now I'm just tryng to run a simple HelloWorld and I still get unresolved inclusions and include errors. I'm sure this is a really noob question, but I would appreaciate any help. Am I missing any basic set up?

By the way, I was using 2017.2 first but I now I'm trying on 2016.4 and it's still the same.

Thank you.

Diana

Xilinx Employee
Posts: 295
Registered: ‎10-21-2010

Re: undefined inclusion and can't find include

Hi @diana_rz,

 

Can you please post the error log from HelloWorld app?

 

Visitor
Posts: 5
Registered: ‎09-06-2017

Re: undefined inclusion and can't find include

Hi, @sadanan, I'm sorry for taking so long to respond; I had some troubles with Vivado, I was for some reason not able to open it anymore, so I decided to uninstall both 2017 and 2016 versions and installed the 2018v.

I just ran the Hello World app and didn't get any errors nor "unresolved inclusion" warnings. I noticed that when I installed it my antivirus scanned rdi_xsct file as a virus, this time I added it as an exception but I'm pretty sure I had let the antivirus handle it the previous times, could this have something to do with not finding the library files? Or is it completely unrelated?

 

Diana