cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Participant
Participant
324 Views
Registered: ‎02-27-2020

v2018.3 Memory test for ZCU102

Hi

I executed Memory Test application generated as sample application of sdk2018.3 on ZCU102.
I attached the result (memtst).

As you can see, check of psu_ddr0 starts from 0x50 base address.
I have no idea why it starts from 0x0 because I think ddr0 should be mapped 0x0 base address.

Actually, the memory test application generated with vitis2020.1 can checked ddr0 from 0x0 base address correctly.

Have you ever had same situation?

I'm afraid if it was caused of a board revision. I used ZCU102 rev1.1 in this test.

Is it possible that v2018.3 tools could not support ZCU102 rev1.1?

I already confirmed that my ZCU102 rev1.1 has labeled 0432055-04 according to the answer below.
https://www.xilinx.com/support/answers/71961.html

 

BestRegards

2 Replies
Moderator
Moderator
245 Views
Registered: ‎03-25-2019

Hi @u-sui,

This is a known bug that has been fixed starting from 2020.1.
Please use 2020.1 or a later version.

Best regards,
Abdallah
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
0 Kudos
Reply
Participant
Participant
192 Views
Registered: ‎02-27-2020

Hi Adballah

Thank you for your reply.

I have understood that the memory test problem I faced in v2018.3 was just a bug.

Is it just display problem? And is it only for zcu102?

I want to confirm that the memory test application in v2018.3 check a whole memory area actually.

BestRegards
u-sui

0 Kudos
Reply