UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie rcfox
Newbie
6,016 Views
Registered: ‎12-11-2009

2.6.31 on ML403 - Builds and boots, but no output

Hello,

I'm trying to get 2.6.31 from the Xilinx Git repo working on my ML403, and I'm very close, but I've run into a wall.

 

Some background:

I followed the instructions here http://npg.dl.ac.uk/MIDAS/DataAcq/EmbeddedLinux.html to get 2.6.25-rc9 working. It works very well, and I've set it up to start an ssh server, etc. However, 2.6.25 doesn't seem to have support for the OV534 GSPCA driver, which I need to interface with my camera. 

 

So now I'm trying to get 2.6.31 to work, since it does have support for this driver. However, the only output I can get over the serial port is:

 

 

zImage starting: loaded at 0x00400000 (sp: 0x0056deb0)

Allocating 0x325679 bytes for kernel ...

gunzipping (0x00000000 <- 0x0040d000:0x0056cacc)...done 0x2f1e10 bytes

 

Linux/PowerPC load: ip=off root=/dev/xsa2 rw console=ttyUL0

Finalizing device tree... flat tree at 0x57a300

 
I've also been able to see the system log over JTAG, but not all of the services start up (like ssh), and reading the system log seems to cause the kernel to crash. 

 

 

I've tried several things:

1. Using the reference design from the link about, with a modified virtex405-ml405.dts to match the values from the xparameters_ml403.h file also provided from the link above. However, there seem to be more parameters in the xparameters file than in the device tree file, and I didn't know what to call them, so I wasn't too confident in this working.

 

2. Making my own bitstream/device tree to build against. I don't have any experience with building a system in an FPGA, so I mostly stuck to the defaults in the wizard.

 

3. I've tried both UARTLite and the 16550 serial ports, since I've read that some people have had problems with the UARTLite.

 

4. I've also tried to match the peripheral values to those in the xparameters file from above. 

 

Is there anything I'm missing here?

 

Would it possible for someone to provide the project files to build a bitstream that will work?

 

Thanks,

Ryan Fox 

 

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
6,014 Views
Registered: ‎09-10-2008

Re: 2.6.31 on ML403 - Builds and boots, but no output

are you following the directions on our wiki, http://xilinx.wikidot.com?

 

That generally looks like something is wrong in your device tree.  I'm assuming you generated a device tree for project to build the kernel.

 

You should be able to use your edk project that you were running the old 2.6.25 kernel on fine.

 

You can compare your device to the one we provide in arch/powerpc/boot/dts/virtex405-ml405.dts.

 

Make sure you have the console right for sure.

 

I don't build anything on the ML403 is the problem, I use the ML405, same board, bigger FPGA.  The BSB defaults are pretty good for a basic system.

 

The kernel debug page on the wiki may help also.  You should be able to dump the log_buf from memory using XMD to get more info.

 

I would also recommend to download our ramdisk image and boot from that 1st rather than system ace as it's simpler.

 

Thanks. 

 

 

 

0 Kudos
Participant jiangyuebing
Participant
5,992 Views
Registered: ‎02-24-2009

Re: 2.6.31 on ML403 - Builds and boots, but no output

I have the same problem. My build elf ran and gave the result as yours. But when I stop the process and check the registers using "rrd". It shows "pc" is jumping between quite low addresses "0x0240" to maybe "0x0260" and never stop. I have not the output further either.

 

 

0 Kudos
Newbie regan_aung
Newbie
5,973 Views
Registered: ‎12-14-2009

Re: 2.6.31 on ML403 - Builds and boots, but no output

Hi

 

For me, I could successfully boot Linux 2.6 on PPC of ML403 board by mainly following XAPP1107.

I could share the built elf file and bit file if you are interested it out. Let me know.

 

 

 

0 Kudos
Participant jiangyuebing
Participant
5,956 Views
Registered: ‎02-24-2009

Re: 2.6.31 on ML403 - Builds and boots, but no output

I solved my problem by simply getting rid of useless modules. It's dirty but works.
0 Kudos
Participant jiangyuebing
Participant
5,953 Views
Registered: ‎02-24-2009

Re: 2.6.31 on ML403 - Builds and boots, but no output

You can check this. 

 

http://forums.xilinx.com/xlnx/board/message?board.id=ELINUX&thread.id=1705

 

That means your ramdisk is too large. when you uncompress it. it covers the bootstrap code.

0 Kudos
Visitor fedoryka
Visitor
5,929 Views
Registered: ‎12-10-2009

Re: 2.6.31 on ML403 - Builds and boots, but no output

If I understand correctly, you're upgrading from 2.6.25 to 2.6.31.  Do you have any modules from 2.6.25 in your rootfs?  I had the same problem building for 2.6.29 and noticed that I still had 2.6.10 modules in lib/modules.  When I removed the "2.6.10" directory the boot continued.

0 Kudos