UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer thburghout
Observer
1,794 Views
Registered: ‎10-27-2017

Re: AXI DMA with Zynq Running Linux

Jump to solution
Hi davirol,

I do think that petalinux takes control of the dma device by default. By importing the hw design during petalinux configuration it sets up a generated device tree.

During boot linux can scan these devices for devices which require drivers to be probed. You might want to hide this part of the device tree. See "Configuring Devicetree" from UG1144.

You should also double check whether the xilinx dma driver is disabled in the rootfs config.

To clarify, I have not used DMA baremetal next to petalinux so I'm not sure whether this is the solution to your problem.

I you have any updates, please let me know. I might need to use this technique in the future.

Thomas
0 Kudos
Highlighted
Newbie jvillal
Newbie
1,742 Views
Registered: ‎12-15-2017

Re: AXI DMA with Zynq Running Linux

Jump to solution

Hi davirol,

 

I am facing the exact same problem as you were: I am running petalinux in CPU0 and baremetal application in CPU1, where I implemented DMA transactions. I've been working with the baremetal application (running on CPU0 and no petalinux) for eight months with no issue, but it is not working when I use petalinux.

 

Did you get any further getting it up and running?

 

Any help will be very very appreciated.

0 Kudos
Contributor
Contributor
552 Views
Registered: ‎05-03-2018

Re: AXI DMA with Zynq Running Linux

Jump to solution
Remove your pl330 DMA driver,everyting is oK !
petalinux-config -c kernel
find dma pl330 driver ,unlock it.
0 Kudos