UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor magicphoton
Visitor
4,395 Views
Registered: ‎05-18-2014

AXI Ethernet Lite driver in Avnet LX9 microboard not working

Hello,

 
I am trying to load linux kernel in an Avnet LX9 microboard. I am working with “Linux/microblaze 3.14.0 Kernel Configuration”, the prebuilt “microblaze-le_minimal.cpio.gz” init ram file system and using the Xilinx AXI Ethernet Driver. I followed Xilinx Wiki for Ethernet lite driver http://www.wiki.xilinx.com/Linux+Emaclite+Driver but when I run linux and type the command: “# ifconfig eth0 192.168.0.155 netmask 255.255.255.0 up” I receive: 

 

net eth0: of_phy_connect() failed

ifconfig: SIOCSIFFLAGS: No such device

 

I have verified that ethernet is working properly in this board with another working petalinux version. I have also tried to change the phy address from 7 to 0 but I have obtained the same error.

 

mdio {

#address-cells = <1>;

#size-cells = <0>;

phy0: phy@0 {

compatible = "marvell,88e1111";

device_type = "ethernet-phy";

reg = <0>;

} ;

} ;

 

Any suggestion? I have attached the next files: xilinx.dts, LX9_Kernel.config, Kernel_console_load.rtf


Thanks for your time and best regards,

MagicPhoton

 

0 Kudos