UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
5,121 Views
Registered: ‎02-14-2014

AXI IRQ Controller and petalinux 2014.2 device tree generator problem

In a similar situation to this post: http://forums.xilinx.com/t5/Embedded-Linux/Petalinux-driver-for-AXI-Interrupt-Controller-core/td-p/524301 I am trying to extend the number of Zynq PL interrupts with an AXI controller. 

 

After adding an AXI Interrupt controller to my design in Vivado (2014.2),  the petalinux-config now fails to generate the device tree with these errors:

 

****** hsm v2014.2
**** SW Build 928826 on Thu Jun 5 17:59:37 MDT 2014
** Copyright 1986-2014 Xilinx, Inc. All Rights Reserved.

INFO: [Hsm 55-1698] elapsed time for repository loading 0 seconds
source /opt/petalinux-v2014.2-final/etc/hsm/scripts/petalinux_hsm_bridge.tcl -notrace
can't read "errorCode": no such variable
while executing
"puts stderr "Error code: ${errorCode}.""
(procedure "plnx_error_exit" line 2)
invoked from within
"plnx_error_exit "HSM failed to generate dts""
(procedure "prepare_dt_bsp" line 12)
invoked from within
"prepare_dt_bsp"
invoked from within
"if {[string equal -nocase $target_app "u-boot_bsp"]} {
add_def_ip_list
uboot_config_gen
} elseif {[string equal -nocase $target_app "device-tree"]} ..."
(file "/opt/petalinux-v2014.2-final/etc/hsm/scripts/petalinux_hsm_bridge.tcl" line 443)
INFO: [Common 17-206] Exiting hsm at Wed Sep 24 12:22:58 2014...
5: extra characters after command
ERROR: [Hsm 55-1695] Unknown interrupt sensitivity LEVEL_HIGH:LEVEL_HIGH:LEVEL_HIGH
make[1]: *** [autogen-dts] Error 1
make: *** [post-config-auto-dts] Error 255

 

I have had a quick look at the tcl code and it seems to be confused by the three (input) interrupt sensitivities with a colon, it is expecting just one.

Does anyone have any ideas here - has this IP been tested/is it supported with petalinux 2014.2, or am I doing something else wrong?   

 

 

 

 

0 Kudos
2 Replies
Visitor dev_luciom
Visitor
5,107 Views
Registered: ‎01-16-2014

Re: AXI IRQ Controller and petalinux 2014.2 device tree generator problem

Hello,

I encounter the same problem,trying to connect 4 interrupt lines to an "AXI Interrupt Controller" via a "Concat" IP. I also use Vivado 2014.2 and Petalinux 2014.2. Have you find a solution to your problem?

 

ERROR: Failed to post config linux
ERROR: Failed to config subsystem linux.
ERROR: [Hsm 55-1695] Unknown interrupt sensitivity EDGE_RISING:EDGE_RISING:EDGE_RISING:EDGE_RISING
make[1]: *** [autogen-dts] Error 1
make: *** [post-config-auto-dts] Error 255

 

Thanks in advance.

 

Best regards,

Sylvain

0 Kudos
Participant eduardoparra
Participant
962 Views
Registered: ‎06-28-2016

Re: AXI IRQ Controller and petalinux 2014.2 device tree generator problem

Hi,

I have the same problem, did you manage to solve it??

0 Kudos