UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer davethetroll
Observer
741 Views
Registered: ‎02-26-2018

App not copied into Linux image

Jump to solution

I have followed the instructions in UG981 Petalinux Application Development Guide to add a test application "cpp_created" to a linux image.  I have created the app and configured the rootfs to include it.  When I make the image the messages imply that all is well

 

Including (most importantly, I assume)
[INFO ] install linux/rootfs/cpp_created.

However, when I boot into Linux on the MicroZed, there is no sign of cpp_created.  It does not exist in the /bin folder.

Am I right to expect to see it there?

Is there any known reason why it would not appear?

I'm using Vivado/XSDK and PetaLinux 2016.2.

0 Kudos
1 Solution

Accepted Solutions
Observer davethetroll
Observer
872 Views
Registered: ‎02-26-2018

Re: App not copied into Linux image

Jump to solution

I discovered my problem.

First success.  When I tried booting this from SD card.  It worked.  The app was there in /bin and ran fine.

Previously I had been calling

petalinux-boot --jtag --prebuilt 3


, as this is the only thing I have found suggested in any of the bring up/getting started guides.

However, if I boot with

petalinux-boot --jtag --u-boot

or

petalinux-boot --jtag --prebuilt 2

then it all works correctly.

However, taking these options for --qemu fails to boot with "Card did not respond to voltage select!"

View solution in original post

0 Kudos
4 Replies
713 Views
Registered: ‎04-20-2017

Re: App not copied into Linux image

Jump to solution
Can u post the .bb from your app?
0 Kudos
Observer davethetroll
Observer
705 Views
Registered: ‎02-26-2018

Re: App not copied into Linux image

Jump to solution

.bb?

Where do I find that?

0 Kudos
Observer davethetroll
Observer
693 Views
Registered: ‎02-26-2018

Re: App not copied into Linux image

Jump to solution

Searching some documents, I notice that the 2016.2 version of UG1144 makes no reference to .bb, the 2017.1 has many.

I'm guessing that is why I can't find any .bb.

 

What is the 2016.2 equivalent?

0 Kudos
Observer davethetroll
Observer
873 Views
Registered: ‎02-26-2018

Re: App not copied into Linux image

Jump to solution

I discovered my problem.

First success.  When I tried booting this from SD card.  It worked.  The app was there in /bin and ran fine.

Previously I had been calling

petalinux-boot --jtag --prebuilt 3


, as this is the only thing I have found suggested in any of the bring up/getting started guides.

However, if I boot with

petalinux-boot --jtag --u-boot

or

petalinux-boot --jtag --prebuilt 2

then it all works correctly.

However, taking these options for --qemu fails to boot with "Card did not respond to voltage select!"

View solution in original post

0 Kudos