UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor shahradp
Visitor
7,984 Views
Registered: ‎04-04-2008

BlueCat and Spartan 3E starter kit

Hello all,

 

I am trying to use Bluecat Linux distrubition on Spartan 3E starter kit. But generating libraries make this problem

 

ERROR:MDT - linux_bc54 () - integer value too large to represent
       while executing
   "format "0x%08X" $param_value"
       ("STD_LOGIC_VECTOR*" arm line 6)
       invoked from within
   "switch -regexp $data_type {
           INTEGER {
           set param_value [string map {_ ""} $param_value]
           }
           STD_LOGIC_VECTOR* {
           set param_value [strin..."
       (procedure "add_xparam_peripheral" line 22)
       invoked from within
   "add_xparam_peripheral $xparam_file $periph_string $args"
       (procedure "add_xparam_driver" line 52)
       invoked from within
   "add_xparam_driver $xparam_file $drv"
       (procedure "add_xparam_drivers" line 16)
       invoked from within
   "add_xparam_drivers $drvlist"
       (procedure "::sw_linux_bc54_v1_00_a::post_generate" line 22)
       invoked from within
   "::sw_linux_bc54_v1_00_a::post_generate 52882264"
ERROR:MDT - Error while running "post_generate" for processor microblaze_0...
make: *** [microblaze_0/lib/libxil.a] Error 2
Done!

 

Apparently is the parameter XPAR for BRAM has a value  a long hex value.

 

I have two question?

 1 - Is bluecat can work on spartan3E starter kit? I cannot see any xprarmeters.h in linux tree for microblaze?

 2 - Is there any working linux for microblaze under spartan 3e?

 

 

Thanks in advance 

 

0 Kudos
2 Replies
Visitor mna75
Visitor
7,406 Views
Registered: ‎06-04-2008

Re: BlueCat and Spartan 3E starter kit

Hello everyone,

I'm also getting this error... What is wrong? Is there any way to fix it?

Waiting for your response.

Thanx for any help.

0 Kudos
6,876 Views
Registered: ‎07-17-2008

Re: BlueCat and Spartan 3E starter kit

I am also facing the same error.

In order to debug, I added some puts in the scripts.

The integer value that is too large is "0x000002FC000002FC000002FC000002FC000002FC000002FC000002FC000002FC" in my system. Parameter name is C_CTRL_BRAM_INIT_xx

I found out that this value is defined in "__xps/DDR_SDRAM_mpmc_ctrl_path_params.v" and in "hdl/ddr_sdram_wrapper.v" files.

Since these files are automatically generated, I have not tried to modify them.

 

Can anybody suggest the solution?

Maybe we are missing somthing while configuring the IP's.

 

Is this someway related to the "mark to initilise BARM" under software projects->default: microblaze_0_bootloop?

 

Thanks.

0 Kudos