UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant 365972698@qq.com
Participant
10,049 Views
Registered: ‎08-09-2015

Boot from QSPI occurs “SF: Unsupported flash IDs: manuf 00” when startup with XMD tools.

Jump to solution

Hi:

    I am trying to boot ZYNQ from QSPI with a demo.

    I do not want to erase the flash in case it can not bootup after reset.

   So I try to  boot ZYNQ in the JTAG mode like following:  

 

   

XMD%connect arm hw

JTAG chain configuration
--------------------------------------------------
Device   ID Code        IR Length    Part Name
 1       4ba00477           4        arm_dap
 2       13722093           6        xc7z010

--------------------------------------------------
Enabling extended memory access checks for Zynq.
Writes to reserved memory are not permitted and reads return 0.
To disable this feature, run "debugconfig -memory_access_check disable".

--------------------------------------------------

CortexA9 Processor Configuration
-------------------------------------
Version.............................0x00000003
User ID.............................0x00000000
No of PC Breakpoints................6
No of Addr/Data Watchpoints.........4

Connected to "arm" target. id = 64
Starting GDB server for "arm" target (id = 64) at TCP port no 1235
XMD% source ps7_init.tcl
XMD% ps7_init
PCW Silicon Version : 3.0
XMD% dow u-boot.elf
Processor started. Type "stop" to stop processor
Processor Stop Condition Unknown
Processor Reset .... DONE
Downloading Program -- u-boot.elf
	section, .text: 0x04000000-0x040407a7
	section, .rodata: 0x040407a8-0x0404fcf2
	section, .hash: 0x0404fcf4-0x0404fd1f
	section, .data: 0x0404fd20-0x0405224b
	section, .got.plt: 0x0405224c-0x04052257
	section, .u_boot_list: 0x04052258-0x04052aeb
	section, .rel.dyn: 0x04052aec-0x0405bc63
	section, .bss: 0x04052aec-0x046a6143
Download Progress.10.20.30.40.50.60.70.80.90.Done
Setting PC with Program Start Address 0x04000000
XMD% con

 

  I can see the  U-BOOT info in the console while the "con" command line typing:

 

U-Boot 2015.04 (Sep 05 2015 - 23:32:58)

Board:	Xilinx Zynq
I2C:   ready
DRAM:  ECC disabled 512 MiB
MMC:   zynq_sdhci: 0
SF: Unsupported flash IDs: manuf 00, jedec 0000, ext_jedec 00ef
*** Warning - spi_flash_probe() failed, using default environment

In:    serial
Out:   serial
Err:   serial
Board:	Xilinx Zynq
Net:   Gem.e000b000
Hit any key to stop autoboot:  3  2  1  0 
Copying Linux from QSPI flash to RAM...
SF: Unsupported flash IDs: manuf 00, jedec 0000, ext_jedec 00ef
Failed to initialize SPI flash at 0:0
zynq-uboot>  

   The CPU appears hang off  for I have no reponse when I type the ENTER button

 

   I also see a post which has a same phenomenon ( https://forums.xilinx.com/t5/Embedded-Linux/SF-Unsupported-manufacturer-00-unable-to-boot-linux-with-ADI/m-p/346705#M6686), but it seems that we have a different problem.

 

when I define the macro DEBUG in the u-boot , I can see the detail error info like this:

 

SF: Got idcodes
00000000: 00 00 00 00 ef 40
SF: Unsupported flash IDs: manuf 00, jedec 0000, ext_jedec 00ef

  I have a  W25Q128BV QSPI on the board  which has a jedec id of  0xef4018.I dont know why.

  I have serveral question :

 

  1: Why the QSPI can not be probed successfully?

  2: Why the CPU seems hanged off  in the command line   zynq-uboot> ? Is the error caused by the failed QSPI probe? 

  3: Without the method of  XMD startup and flash programme, how can I debug the FSBL with the file fsbl.elf?

 

  Can anyone help me ? Thanks very much! 

 

 

 

 

 

 

 

 

 

TONNY
0 Kudos
1 Solution

Accepted Solutions
Participant 365972698@qq.com
Participant
18,727 Views
Registered: ‎08-09-2015

Re: Boot from QSPI occurs “SF: Unsupported flash IDs: manuf 00” when startup with XMD tools.

Jump to solution

I have solve my problems.

All the errors are caused by the hardware configs. like voltage , clock etc.

Till now I think the only way to debug FSBL  is to programme the QSPI flash(the QSPI startup method).

thanks all !

TONNY
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
10,009 Views
Registered: ‎07-23-2012

Re: Boot from QSPI occurs “SF: Unsupported flash IDs: manuf 00” when startup with XMD tools.

Jump to solution
Were you able to program the flash through SDK or Vivado device programmer?

This will give us a clue whether the issue lies in hardware or U-boot.
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos
Participant 365972698@qq.com
Participant
18,728 Views
Registered: ‎08-09-2015

Re: Boot from QSPI occurs “SF: Unsupported flash IDs: manuf 00” when startup with XMD tools.

Jump to solution

I have solve my problems.

All the errors are caused by the hardware configs. like voltage , clock etc.

Till now I think the only way to debug FSBL  is to programme the QSPI flash(the QSPI startup method).

thanks all !

TONNY
0 Kudos