cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
5,520 Views
Registered: ‎09-05-2014

Cannot build Petalinux with perl modules

In Petalinux v2013.10-final, I'm trying to use some Perl modules. I can build petalinux with perl, but only if I select no modules.

 

When I select e.g. perl-module-io-socket-inet in the petalinux-config -c rootfs, a bunch of dependent modules are also selected. But, petalinux-build no longer works.

 

How can I use these Perl modules?

 

[ALL  ] Some packages could not be installed. This may mean that you have       
[ALL  ] requested an impossible situation or if you are using the unstable      
[ALL  ] distribution that some required packages have not yet been created      
[ALL  ] or been moved out of Incoming.                                           
[ALL  ] The following information may help to resolve the situation:            
[ALL  ]                                                                         
[ALL  ] The following packages have unmet dependencies:                         
[ALL  ]  perl-module-b : Depends: perl-module-strict but it is not installable  
[ALL  ]  perl-module-carp : Depends: perl-module-strict but it is not installable
[ALL  ]                     Depends: perl-module-warnings but it is not installable
[ALL  ]  perl-module-cgi : Depends: perl-module-config but it is not installable
[ALL  ]  perl-module-cgi-cookie : Depends: perl-module-warnings but it is not installable
[ALL  ]                           Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-cgi-util : Depends: perl-module-vars but it is not installable
[ALL  ]                         Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-constant : Depends: perl-module-strict but it is not installable
[ALL  ]                         Depends: perl-module-vars but it is not installable
[ALL  ]                         Depends: perl-module-warnings-register but it is not installable
[ALL  ]  perl-module-dynaloader : Depends: perl-module-config but it is not installable
[ALL  ]  perl-module-exporter-heavy : Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-fcntl : Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-list-util : Depends: perl-module-vars but it is not installable
[ALL  ]                          Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-list-util-pp : Depends: perl-module-vars but it is not installable
[ALL  ]                             Depends: perl-module-warnings but it is not installable
[ALL  ]                             Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-mro : Depends: perl-module-warnings but it is not installable
[ALL  ]                    Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-overload : Depends: perl-module-warnings-register but it is not installable
[ALL  ]  perl-module-scalar-util : Depends: perl-module-vars but it is not installable
[ALL  ]                            Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-scalar-util-pp : Depends: perl-module-vars but it is not installable
[ALL  ]                               Depends: perl-module-warnings but it is not installable
[ALL  ]                               Depends: perl-module-strict but it is not installable
[ALL  ]  perl-module-socket : Depends: perl-module-warnings-register but it is not installable
[ALL  ]                       Depends: perl-module-strict but it is not installable
[ERROR] E: Broken packages                                                      
[ERROR] make[2]: *** [pkg_rootfs_expand] Error 255
0 Kudos
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
5,504 Views
Registered: ‎12-17-2007

Re: Cannot build Petalinux with perl modules

Try taking a look at this AR to see if it helps:

http://www.xilinx.com/support/answers/59802.html
-------------------------------------------
this space intentionally left blank
0 Kudos