cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
szczepan003
Visitor
Visitor
351 Views
Registered: ‎07-24-2019

Core Dump when Executing Xilinx Qemu

Hello All, 

I am trying to launch a Qemu session for the zcu102 board.I am using a 64bit ARM host running Linux Kernel 4.14.0-115.el7a.0.1.aarch64 and CentOS7. 

After discovering the Xilinx Github repo for Qemu, and subsequent documentation about using it for the zcu102 board, I followed the instructions on the Xilinx confluence page to download, configure, and build the latest Qemu from Xilinx. I am following the instructions outlined in this confluence page specifically https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842060/QEMU . This includes using the following configure before building 

./configure --target-list="aarch64-softmmu,microblazeel-softmmu" --enable-fdt --disable-kvm --disable-xen

The configure and build process complete without any errors, but when I try to execute the binary that is generated (./aarch64-softmmu/qemu-system-aarch64) with and/or without launch options the binary seg faults and core dumps. I would expect even the Xilinx build of Qemu to support the "-M help" or "-help" launch arguments, but even those result in the seg fault. A GDB of the binary doesnt reveal too much for me, but I will post the back trace just in case its useful. 

(gdb) backtrace
#0  0x0000ffffbdd2683c in strlen () from /lib64/libc.so.6
#1  0x0000ffffbe0ffa48 in g_strdup () from /lib64/libglib-2.0.so.0
#2  0x000000000078fb48 in type_new (info=0xa46d58 <mdio_slave_info>) at qom/object.c:127
#3  0x0000000000790c08 in type_register_internal (info=<optimized out>) at qom/object.c:137
#4  type_register (info=<optimized out>) at qom/object.c:146
#5  0x0000000000859f68 in module_call_init (type=type@entry=MODULE_INIT_QOM) at util/module.c:98
#6  0x000000000041daa0 in main (argc=1, argv=0xfffffffff388, envp=<optimized out>) at vl.c:3153

Any ideas what the issue may be? I am able to download the Upstream Qemu (https://github.com/qemu/qemu), but wanted to try to use the Xilinx fork of Qemu for compatibility with the ZCU102 BSP/Board Models in a Qemu session as I have had separate issues launching them with the Upstream Qemu. 

 

Thanks for any information. 

Dylan

0 Kudos
0 Replies