UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
7,576 Views
Registered: ‎03-13-2012

Error building u-boot

Jump to solution

Hi all,

 

I'm experiencing an error when building u-boot as part of the overall ISE14.6 and PetaLinux v2013.04 build for Zynq. I've got a working toolchain, have compiled and deployed linux on my board target, and now I'm hit with this...

 

I'm following UG980, as per pg. 15 - Configuring Software Settings of the Hardware Project. I created the petalinux BSP, and selected stdin/out, DRAM, and ethernet with it. I then ran the whole command line PetaLinux process with the petalinux-copy-autoconfig command, and (eventually) run make here:

$ cd $PETALINUX/software/petalinux-dist
$ make
 
I got the following error when doing make:
... lots of build stuff...
[INFO ] Configuring u-boot
[INFO ] Building u-boot
[ERROR] arm-xilinx-linux-gnueabi-ld: error: required section '.rel.plt' not found in the linker script
[ERROR] make[1]: *** [u-boot] Error 1
[00:05] \ make: *** [u-boot] Error 255

If I remove the ethernet Value in the petalinux BSP (using SDK), this error goes away, but then u-boot isn't built with networking and isn't capable of running tftp etc. What is this error and how do I fix it?
 
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
10,853 Views
Registered: ‎08-02-2007

Re: Error building u-boot

Jump to solution

Hi Vadim,

 

Can you try to go to Uboot folder and run the following commands:-

 

$ make clean;

$ make mrproper

 

--HS

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
10,854 Views
Registered: ‎08-02-2007

Re: Error building u-boot

Jump to solution

Hi Vadim,

 

Can you try to go to Uboot folder and run the following commands:-

 

$ make clean;

$ make mrproper

 

--HS

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

View solution in original post

0 Kudos
7,549 Views
Registered: ‎03-13-2012

Re: Error building u-boot

Jump to solution

Worked like a champ. Thanks Hem!

0 Kudos