UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer manikumar086
Observer
1,719 Views
Registered: ‎01-03-2011

Ethernet LL TEMAC (1G) packets not receiving in Linux Kernel

Hi,

 

I'm facing an Ethernet packet reception error in Linux Kernel (tried using PING command), whereas the same is working with U-Boot (PING command).

 

Please find version details of each below :

Xilinx Linux Kernel : 2.6.35 and also tried with 3.12.0

Xilinx U-Boot : 2010

Xilinx EDK/SDK : 13.4

 

System Setup :

  1. Current EDK setup uses Ethernet TEMAC (GMII) and an RTL Bridge to convert GMII to SGMI

Observations of Linux Kernel:

  1. Transmitting of Ethernet packets from board to PC is happening, verified using wireshark tool by issuing PING command and TFTP.
  2. Receiving of Ethernet ARP packets happening and Linux Kernel sending the response back of ARP requests to PC also.
  3. But receiving of Ethernet packets other than ARP in Linux Kernel is not happening (tested using PING, TFTP, FTP, TELNET communications).
  4. Response of ping command getting success when it is pinged using loop back address but failing with PC address.
  5. Debug prints observation :
    1. After adding prints in ICMP send/receive routines, it is observed that both routine prints are printing when pinged using loop back address and only send routine prints printing when pinging to PC.
    2. Added prints in Ethernet packet receive handlers and it is observed that all time packet received prints are coming when pinging using PC/Loop back address.
    3. Observation with Ethernet packet counters displayed using IFCONFIG command in Linux Kernel :
      1. Transmit counters and Receive counters are incrementing when a ping command issued to either PC or loop back address.
      2. Error counters of both Transmit and receive counters were zero.
      3. Information the Linux Version 3.12.0 ported on other Hardware and Ethernets are working fine.

 

Observation of U-Boot :

  1. Transmitting and reception of Ethernet packs is working.
  2. Tested using PING command and file transferred using TFTP.

Thanks in advance.

 

Mani Kumar

0 Kudos
1 Reply
755 Views
Registered: ‎10-29-2015

Re: Ethernet LL TEMAC (1G) packets not receiving in Linux Kernel

Hi,

 

 

We are also facing same issue and we are using Xilinx ML507 ( Virtex 5) board for same.

Did you get any soultion on this ? It would be great if you share your expereince.

 

 

Thanks

Venkatesh Raju

 

 

 

0 Kudos