cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
user9995
Visitor
Visitor
1,436 Views
Registered: ‎10-01-2019

FPGA Manager + FSBL bitstream (Petalinux 2019.2)

Jump to solution

Hi,

I've noticed that when I enable FPGA manager in petalinux configuration, petalinux-package does not allow loading a bitstream into BOOT.BIN for the FSBL to load. What is the reason for this limitation?

So does this mean if you want to dynamically load the PL from linux after boot you can can no longer have the PL loaded during FSBL or U-BOOT?

I'm using petalinux tools 2019.2 targetting a MPSOC.

Thanks,
Paul

1 Solution

Accepted Solutions
user9995
Visitor
Visitor
1,193 Views
Registered: ‎10-01-2019

Running bootgen directy did seem to work. However it seems you don't need FPGA manager enabled in petalinux-config to load bin files internally (kernel driver is still enabled). When its disabled then petalinux-package seems to let you insert bit files into BOOT.BIN.

View solution in original post

4 Replies
chaoz
Xilinx Employee
Xilinx Employee
1,378 Views
Registered: ‎09-14-2018

Hi @user9995 

I don't think it should be like that. Could you post your logs after running petalinux-package command?

0 Kudos
Reply
user9995
Visitor
Visitor
1,372 Views
Registered: ‎10-01-2019

Hi @chaoz 

output after running "petalinux-package --boot --fpga --u-boot --pmufw --force"

 

WARNING: Fpga Manager enabled, skipping bitstream to pack into BOOT.BIN
INFO: File in BOOT BIN: "/data/paul/projects/lib3/lib_fw/sw/prj/petalinux/htg/petalinux_htg_bsp/images/linux/zynqmp_fsbl.elf"
INFO: File in BOOT BIN: "/data/paul/projects/lib3/lib_fw/sw/prj/petalinux/htg/petalinux_htg_bsp/images/linux/pmufw.elf"
INFO: File in BOOT BIN: "/data/paul/projects/lib3/lib_fw/sw/prj/petalinux/htg/petalinux_htg_bsp/images/linux/bl31.elf"
INFO: File in BOOT BIN: "/data/paul/projects/lib3/lib_fw/sw/prj/petalinux/htg/petalinux_htg_bsp/images/linux/u-boot.elf"
INFO: Generating zynqmp binary package BOOT.BIN...


****** Xilinx Bootgen v2019.2
  **** Build date : Oct 23 2019-22:59:42
    ** Copyright 1986-2019 Xilinx, Inc. All Rights Reserved.

INFO: Binary is ready.

 

 

First line gives warning that it does not insert bitstream into BOOT.BIN

You can also see this in the bif generated during package that it does not contain the bitstream:

the_ROM_image:
{
        [bootloader, destination_cpu=a53-0] /tmp/tmp.XjhYr1MWLL/zynqmp_fsbl.elf
        [pmufw_image] /tmp/tmp.XjhYr1MWLL/pmufw.elf 
        [destination_cpu=a53-0, exception_level=el-3, trustzone] /tmp/tmp.XjhYr1MWLL/bl31.elf
        [destination_cpu=a53-0, exception_level=el-2] /tmp/tmp.XjhYr1MWLL/u-boot.elf
}

Thanks,
Paul

chaoz
Xilinx Employee
Xilinx Employee
1,345 Views
Registered: ‎09-14-2018

hi @user9995 

Ok, if you need, you can try with Bootgen directly or using SDK to do the package.

Maybe tool is getting smartter...

 

 

0 Kudos
Reply
user9995
Visitor
Visitor
1,194 Views
Registered: ‎10-01-2019

Running bootgen directy did seem to work. However it seems you don't need FPGA manager enabled in petalinux-config to load bin files internally (kernel driver is still enabled). When its disabled then petalinux-package seems to let you insert bit files into BOOT.BIN.

View solution in original post