cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
6,122 Views
Registered: ‎10-28-2013

Failed to open PetaLinux lib

I'm using Xubuntu 13.10 and am going through the petalinux installation guide. I have source petalinux settings and then try  "petalinux-boot-prebuilt --help"  but I get the the error "Failed to open PetaLinux lib, please make sure you have source PetaLinux settings."

 

I have SELinux installed but it is disabled. I have also tried "chcon -R -t textrel_shlib_t lib" like the installation guide suggests but I get "chcon: can't apply partial context to unlabeled file ‘libSecurity.so’".

Any thoughts?

 

Thanks.

0 Kudos
5 Replies
Highlighted
Visitor
Visitor
6,074 Views
Registered: ‎04-12-2010

I have the same problem.  Spent an entire day trying to get petalinux & the BSP installed but stalled on this issue.  Did both the suggestions in the troubleshooter guide.   SELinux is not in "permissive mode" and also changed security level of petalogix to boot.
Ugh....

 

0 Kudos
Highlighted
Newbie
Newbie
6,049 Views
Registered: ‎11-04-2013

I had the same problem, i was installing on a 64 bits system and was missing some 32 bits libraries. Anyway, to find missing libraries do:

       strace petalinux-install-bsp ~/Downloads/Xilinx-ZC706-v2013.04-final.bsp

You will get explicit messages about missing files. A coomon one is libstdc++.so.6, to install it:

        apt-get install lib32stdc++6

 

That fixed the missing libraries problem for me.....

0 Kudos
Highlighted
Visitor
Visitor
6,038 Views
Registered: ‎04-12-2010

Thank you.  That was very helpful input. 

 

My setup:  centos-6.2-x64-virtual-machine

 

1) I can see in the trace it is missing "libstdc++.so.6".

2) sudo yum install -y libstdc++.so.6   

3) Result of yum:

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package libstdc++.i686 0:4.4.7-3.el6 will be installed
--> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: libstdc++-4.4.7-3.el6.i686
--> Processing Dependency: libgcc_s.so.1(GCC_4.2.0) for package: libstdc++-4.4.7-3.el6.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: libstdc++-4.4.7-3.el6.i686
--> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: libstdc++-4.4.7-3.el6.i686
--> Processing Dependency: libgcc_s.so.1 for package: libstdc++-4.4.7-3.el6.i686
--> Running transaction check
---> Package libgcc.i686 0:4.4.7-3.el6 will be installed
--> Finished Dependency Resolution
Error: Protected multilib versions: libstdc++-4.4.7-3.el6.i686 != libstdc++-4.4.6-3.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Ugh... Any help greatly appreciated.

 

 

 

 

0 Kudos
Highlighted
Scholar
Scholar
6,030 Views
Registered: ‎05-28-2013

You're trying to install a 32-bit library into a 64-bit machine, however the version of the 32-bit library is newer that the 64-bit system library.

To fix that, you need to update the system library first:
yum upgrade libstdc++

Then you can go ahead and install the 32-bit version, exactly as you did before.

It would probably be wise to install all the available updates ("yum upgrade").
0 Kudos
Highlighted
Visitor
Visitor
6,020 Views
Registered: ‎04-12-2010

Thanks very much for the help.  Those were the 2 things I needed:

 

sudo yum update -y  // this takes a long time.  It will appear to be hung at the end but it actully has alot more to do.
sudo yum install -y libstdc++.so.6

Hey Xilinx.  Consider just making a premade Centos VM for everyone.  Would be greatly appreciated.

 

0 Kudos