UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer esraaltun
Observer
138 Views
Registered: ‎11-21-2019

Failed to start raise network interface on custom board

Jump to solution

Hi,

I work with custom board (zynq-7035) and use petalinux 2018.3 version. My custom board's ethernet chip is atheros-ar8035. So I used this link for enabling some kernel configuration.( https://forums.xilinx.com/t5/Embedded-Linux/Adding-Qualcomm-Atheros-ath10-support-to-petalinux/td-p/922086)

 

system-user.dtsi

/include/ "system-conf.dtsi"
/ {

};

&gem{
compatible = "cdns,zynq-gem", "cdns,gem";
reg = <0xe000b000 0x1000>;
status = "okay";
interrupts = <0 22 4>;
clocks = <&clkc 30>, <&clkc 30>, <&clkc 13>;
clock-names = "pclk", "hclk", "tx_clk";
#address-cells = <1>;
#size-cells = <0>;
phy-mode = "rgmii-id";
phy-handle = <&phy0>;

phy@0 {
compatible = "atheros,ar8035";
device_type = "ethernet-phy";
reg = <0x0>;
linux,phandle = <0x4>;
phandle = <0x4>;
};
};

It failed. How can I fix it?

Screenshot from 2020-02-13 19-10-46.png

Thanks,

Esra.

0 Kudos
1 Solution

Accepted Solutions
Observer esraaltun
Observer
74 Views
Registered: ‎11-21-2019

Re: Failed to start raise network interface on custom board

Jump to solution

I solved this problem.

petalinux-config -c kernel

Device Drivers -> Network device support -> Ethernet driver support→PHY device support and infrastructure→ at803x(atheros qualcom)

 

And I delete node that added in system-user.dtsi. It fixed, when I enabled at803x option. 

View solution in original post

0 Kudos
1 Reply
Observer esraaltun
Observer
75 Views
Registered: ‎11-21-2019

Re: Failed to start raise network interface on custom board

Jump to solution

I solved this problem.

petalinux-config -c kernel

Device Drivers -> Network device support -> Ethernet driver support→PHY device support and infrastructure→ at803x(atheros qualcom)

 

And I delete node that added in system-user.dtsi. It fixed, when I enabled at803x option. 

View solution in original post

0 Kudos