cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
1,263 Views
Registered: ‎05-10-2019

First Password Attempt Fails

Hi,

I'm running 2019.1. No issues at the UART console but if I try to login via SSH (ssh root@<my-ip-address>) the first attempt always fails. I have a few scripts to copy files and they now fail.

I'm using Dropbear.

Thanks,

Kenny

5 Replies
chen8494
Observer
Observer
1,176 Views
Registered: ‎05-18-2017

Hi kenny

I have the same problem with you ,running 2019.1, and my ftp software filezilla can't access ftp&sftp.

I have a ZCU102 board ,so i try  with xilinx offer “ZCU102 BSP ”. It also have the same problem .

Do you solve the problem ? Do you know how to make  petalinux 2019.1 ftp&sftp work?

thanks

0 Kudos
chen8494
Observer
Observer
1,151 Views
Registered: ‎05-18-2017

I find two ways to solve this problem

1. https://forums.xilinx.com/t5/Embedded-Linux/dropbear-root-login-petalinux-2019-1/m-p/979852?search-action-id=137358904284&search-result-uid=979852

 

2.after boot  run script (uart)

#!/bin/bash

PID=$(ps -e|grep dropbear | grep -v grep|awk '{print $1}')

kill ${PID}

/usr/sbin/dropbear -r /etc/dropbear/dropbear_rsa_host_key -p 22
#!/bin/bash

PID=$(ps -e|grep dropbear | grep -v grep|awk '{print $1}')

kill ${PID}

/usr/sbin/dropbear -r /etc/dropbear/dropbear_rsa_host_key -p 22
abouassi
Moderator
Moderator
904 Views
Registered: ‎03-25-2019

Hi,

I have reported the issue internally to our development team.
Thanks for pointing this out.

Best regards,
Abdallah
-------------------------------------------------------------------------------
Please don't forget to reply, kudo and accept as a solution
0 Kudos
larshb
Adventurer
Adventurer
874 Views
Registered: ‎08-30-2018

Any updates?
Issue tracker?

The same problem does not apply to Telnet, btw.

larshb
Adventurer
Adventurer
866 Views
Registered: ‎08-30-2018

chen8494
Petalinux (at least the one I'm using) is bundled with BusyBox v1.29.2 and there is no flag "-e" for ps (only "w" and "l").