UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor tushar@raj
Visitor
342 Views
Registered: ‎06-07-2018

Getting error in setting up NFS

From: Rajpurohit, Tushar 
Sent: Wednesday, June 6, 2018 5:45 AM
Subject: RE: [External] RE: Getting error in setting up NFS

 

Hi Christophe,

 

I have added replies.

 

Regards,

Tushar

 

 

From: Christophe Charpentier 
Sent: 05 June 2018 07:49 PM
Subject: [External] RE: Getting error in setting up NFS

 

Tushar,

 

Have you checked that you can ping the target from the host?

Yes, I could able to ping the target from the host and vice versa. (I did it in both ways – 1. Linux PC <-> Xilinx board Petalinux 2. Linux PC <-> another Linux PC)

Have you verified that the nfs server is working properly by trying to connect from another PC?

Yes, NFS is working perfectly in a PC, I checked it using a command for NFS services status, as follows:

> systemctl status nfs-server.services

  • nfs-server.service - NFS server and services

   Loaded: loaded (/usr/lib/systemd/system/nfs-server.service; enabled; vendor preset: disabled)

  Drop-In: /run/systemd/generator/nfs-server.service.d

           └─order-with-mounts.conf

   Active: active (exited) since Tue 2018-06-05 11:59:57 IST; 1 day 5h ago

  Process: 18311 ExecStopPost=/usr/sbin/exportfs -f (code=exited, status=0/SUCCESS)

  Process: 18309 ExecStopPost=/usr/sbin/exportfs -au (code=exited, status=0/SUCCESS)

  Process: 18305 ExecStop=/usr/sbin/rpc.nfsd 0 (code=exited, status=0/SUCCESS)

  Process: 18330 ExecStart=/usr/sbin/rpc.nfsd $RPCNFSDARGS (code=exited, status=0/SUCCESS)

  Process: 18325 ExecStartPre=/bin/sh -c /bin/kill -HUP `cat /run/gssproxy.pid` (code=exited, status=0/SUCCESS)

  Process: 18323 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)

Main PID: 18330 (code=exited, status=0/SUCCESS)

   CGroup: /system.slice/nfs-server.service

 

Jun 05 11:59:56 localhost.localdomain systemd[1]: Starting NFS server and ser...

Jun 05 11:59:57 localhost.localdomain systemd[1]: Started NFS server and serv...

Hint: Some lines were ellipsized, use -l to show in full.

 

And I was able to mount NFS share in another PC successfully using this command.

> sudo mount -t nfs XXX.XXX.X.XXX(IP of NFS server):/nfs_share /mnt/nfs_mount

It displayed all the content from nfs_share into nfs_mount.

 

Regards,

 

Christophe

 

 

From: Rajpurohit, Tushar
Sent: 05 June 2018 05:27 PM
Subject: Getting error in setting up NFS

 

Hi Pablo and Christophe,

 

I am working on ZCU102 development board with Xilinx Zynq ultrascale+ for one of our pre-product development. I am using Petalinux SDK environment to build the required boot software and petalinux for the board.  For my prototype study, I need to host the linux filesystem from a NFS server. I am facing issues in mounting the NFS filesystem and I request your team support in getting the help. You can find the details of the steps here.

 

I am using RHEL desktop PC for running the NFS server and file system from the NFS share. I followed the below steps to mount the NFS filesystem.

 

On Server side (RHEL desktop PC) -

  1. Installed NFS services using command - sudo yum install nfs­kernel­server nfs­common portmap
  2. Modify the /etc/exports file with text - /nfs_share/ *(rw,sync,no_root_squash)
  3. Restart the NFS server using command: sudo systemctl restart nfs-server.service

 

On NFS client side (ZynqMP ultrascale+) –

  1. image.ub and BOOT.BIN are generated as follows.
  • Changed directory to petalinux project extracted using .bsp file.
  • Executed the command -  source /opt/pkg/petalinux/settings.sh
  • Executed the command -  petalinux-config
  • In .config settings went to Image Packaging Configuration and change the fields as follows-

Root filesystem type is selected as NFS.

Location of NFS root directory is edited as /nfs_share

NFS server IP address is filled with RHEL desktop’s ethernet IP.

went back and

  • Chose DTG settings and edited the Kernel Bootargs as below –

console=ttyPS0,115200 root=/dev/nfs nfsroot=XXX.XXX.X.XXX(IP of RHEL machine):/nfs_share, tcp ip=dhcp rw

save the config and exit.

  • Executed the command - petalinux-build
  • Executed the command - petalinux-package --boot --fsbl (path to zynqmp_fsbl.elf) --fpga (path to download.bit) --pmufw (path to pmufs.elf) --u-boot --force
  • Load the image.ub and BOOT.BIN file in boot partition of SDcard and boot into board.

 

Getting the following errors

VFS: Unable to mount root fs via NFS, trying floppy.

VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6

Please append a correct "root=" boot option;

---------------------

---------------------

Kernel panic - not syncing: VFS: Unable to mount root fs

 

Regards,

Tushar

0 Kudos