UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
380 Views
Registered: ‎06-19-2018

Hanging at "calibrating delay loop" when I tried to boot my board

my boot log below:

--------------------------------------

U-Boot 2015.04 (Oct 13 2018 - 01:50:41)

Board: Xilinx Zynq
I2C: ready
DRAM: ECC disabled 512 MiB
MMC: zynq_sdhci: 0
SF: Detected S25FL256S_64K with page size 256 Bytes, erase size 64 KiB, total 32 MiB
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Board: Xilinx Zynq
Net: Gem.e000b000
reading uEnv.txt
346 bytes read in 16 ms (20.5 KiB/s)
Importing environment from SD ...
Hit any key to stop autoboot: 0
Device: zynq_sdhci
Manufacturer ID: 41
OEM: 3432
Name: SD16G
Tran Speed: 50000000
Rd Block Len: 512
SD version 3.0
High Capacity: Yes
Capacity: 14.5 GiB
Bus Width: 4-bit
Erase Group Size: 512 Bytes
UENV Copying Linux from SD to RAM...
reading uImage
2723712 bytes read in 254 ms (10.2 MiB/s)
reading devicetree.dtb
9207 bytes read in 27 ms (333 KiB/s)
## Booting kernel from Legacy Image at 03000000 ...
Image Name: Linux-3.3.0
Image Type: ARM Linux Kernel Image (uncompressed)
Data Size: 2723648 Bytes = 2.6 MiB
Load Address: 00008000
Entry Point: 00008000
Verifying Checksum ... OK
## Flattened Device Tree blob at 02a00000
Booting using the fdt blob at 0x2a00000
Loading Kernel Image ... OK
Loading Device Tree to 1f317000, end 1f31c3f6 ... OK

Starting kernel ...

Uncompressing Linux... done, booting the kernel.
Booting Linux on physical CPU 0
Linux version 3.3.0 (yaoxing@ubuntu) (gcc version 4.6.1 (Sourcery CodeBench Lite 2011.09-50) ) #2 SMP PREEMPT Fri Dec 28 04:50:07 PST 2018
CPU: ARMv7 Processor [413fc090] revision 0 (ARMv7), cr=18c5387d
CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache
Machine: Xilinx Zynq Platform
bootconsole [earlycon0] enabled
INITRD: 0x00800000+0x01000000 is not a memory region - disabling initrd
Memory policy: ECC disabled, Data cache writealloc
BUG: mapping for 0xf8f00000 at 0xfe00c000 out of vmalloc space
BUG: mapping for 0xe0001000 at 0xfe001000 out of vmalloc space
BUG: mapping for 0xffff1000 at 0xfe200000 out of vmalloc space
PERCPU: Embedded 7 pages/cpu @c0a94000 s6400 r8192 d14080 u32768
Built 1 zonelists in Zone order, mobility grouping off. Total pages: 4064
Kernel command line: console=ttyPS0,115200n8 root=/dev/ram rw initrd=0x00800000,16M earlyprintk mtdparts=physmap-flash.0:512K(nor-fsbl),512K(nor-u-boot),5M(nor-linux),9M(nor-user),1M(nor-scratch),-(nor-rootfs)
PID hash table entries: 64 (order: -4, 256 bytes)
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 16MB = 16MB total
Memory: 5448k/5448k available, 10936k reserved, 0K highmem
Virtual kernel memory layout:
vector : 0xffff0000 - 0xffff1000 ( 4 kB)
fixmap : 0xfff00000 - 0xfffe0000 ( 896 kB)
vmalloc : 0xc1800000 - 0xfd000000 ( 952 MB)
lowmem : 0xc0000000 - 0xc1000000 ( 16 MB)
pkmap : 0xbfe00000 - 0xc0000000 ( 2 MB)
modules : 0xbf000000 - 0xbfe00000 ( 14 MB)
.text : 0xc0008000 - 0xc04a24d0 (4714 kB)
.init : 0xc04a3000 - 0xc04cb900 ( 163 kB)
.data : 0xc04cc000 - 0xc0507b00 ( 239 kB)
.bss : 0xc0507b24 - 0xc0a1024f (5154 kB)
Preemptible hierarchical RCU implementation.
RCU lockdep checking is enabled.
Verbose stalled-CPUs detection is disabled.
NR_IRQS:128
Xilinx, no compatible timer found, using default
xlnx,ps7-ttc-1.00.a #0 at 0xc1800000, irq=43
Error, no clock-frequency specified for timer
Error, no clock-frequency specified for timer
Console: colour dummy device 80x30
Lock dependency validator: Copyright (c) 2006 Red Hat, Inc., Ingo Molnar
... MAX_LOCKDEP_SUBCLASSES: 8
... MAX_LOCK_DEPTH: 48
... MAX_LOCKDEP_KEYS: 8191
... CLASSHASH_SIZE: 4096
... MAX_LOCKDEP_ENTRIES: 16384
... MAX_LOCKDEP_CHAINS: 32768
... CHAINHASH_SIZE: 16384
memory used by lock dependency info: 3695 kB
per task-struct memory footprint: 1152 bytes
Calibrating delay loop...

-------------------------------------------------------

I built a kernel named "linux-xcomm_zynq", because it includes the adv7511 driver in the kernel. and i make the zynq-zed-adv7511-xcomm.dtb after I got my uImage. But when I use the sd card which loaded the booting files to boot my borad, something wrong happened.

so have you meet this problem? waiting for your reply. 

0 Kudos
1 Reply
Explorer
Explorer
360 Views
Registered: ‎06-03-2015

Re: Hanging at "calibrating delay loop" when I tried to boot my board

Hi 

Root cause  based on error log: The system is expecting a clock interrupt and isn't getting from kernel.

please check your .dts file , which provides all device nodes for the Board , based on defconfig file used,

and check the clock source presented in .defconfig file and corrspending .dts (provides nodes for all device components) should be present.

if cloclsource with node information is present in the Board .dts file, same will be provided to Kernel for doing this "Calibraing delay loop opearation" and will be passed to next statement. 

so It is basiaclly, Kernel wants to do calibrate delay loop opearation, but board is not able to do the same, because board file does not support from .dts .

Either you remove this flag from Menuconfig or provide support from .dts 

First option is not preferable, so provide proper .dts file for the Board.

 

Thanks & Regards

Satish G

G Satish Kumar
0 Kudos