cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
779 Views
Registered: ‎10-16-2019

How-to: Disable BOOTP Broadcast

Is there a way to disable the BOOTP broadcast step (shown below) within U-boot? It takes a fair amount of time, and I know that I want to boot straight from the stored image on an SD card.

ethernet@e000b000 Waiting for PHY auto negotiation to complete....... done
BOOTP broadcast 1
BOOTP broadcast 2
BOOTP broadcast 3
BOOTP broadcast 4
BOOTP broadcast 5
BOOTP broadcast 6
BOOTP broadcast 7
BOOTP broadcast 8
BOOTP broadcast 9
BOOTP broadcast 10
BOOTP broadcast 11
BOOTP broadcast 12
BOOTP broadcast 13
BOOTP broadcast 14
BOOTP broadcast 15
BOOTP broadcast 16

I'm working with a zc702 board, and I need to disable this option in the image that is stored onto the SD card rather than perform any interactive u-boot commands.

I have tried a few things, including disabling ethernet drivers in the options shown in petalinux-config -c u-boot, and I have looked at posts like this one, but I have yet to find anything that works.

0 Kudos
3 Replies
Highlighted
Observer
Observer
612 Views
Registered: ‎05-04-2018

Were you able to resolve this issue? I'm trying to do the same thing -- disable BOOTP broadcasts on boot and use a static IP.

0 Kudos
Highlighted
Contributor
Contributor
277 Views
Registered: ‎09-28-2019

Hello,

Did you resolve the problem?

Tags (1)
0 Kudos
Highlighted
Observer
Observer
271 Views
Registered: ‎05-04-2018

Hello tgharbi2020,

I was able to resolve this by disabling DHCP using petalinux-config:

-> Subsystem AUTO Hardware Settings -> Ethernet Settings:

 
0 Kudos