UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer dmitril
Observer
320 Views
Registered: ‎01-17-2018

How to disable device tree generation?

Jump to solution

Hi,

Our FPGA has several module instances that share the same IRQ. This works OK, but I cannot build Petalinux. It fails in device-tree task with various errors (see below).
I cannot waste time on this clumsy device tree generation tool and instead I would like to make a custom .dts file.
Question is how to prevent Petalinux from running device-tree task
or, at least, that part of device-tree task that generates .dts from .hdf

These are the errors from generate_target:

ERROR: [Hsi 55-1545] Problem running tcl command ::sw_device_tree::generate : missing operator at _@_
in expression "84 _@_85 85 85 85 85 85 85 -..."
(parsing expression "84 85 85 85 85 85 85 8...")
invoked from within
"expr $intr_id - 32"
....

or (after we modified FPGA):

....
| WARNING: Interrupt pin "mm2s_introut" of IP block: "axi_vdma_cam_3_ddr" is not connected to any interrupt controller
| WARNING: Interrupt pin "s2mm_introut" of IP block: "axi_vdma_cam_3_ddr" is not connected to any interrupt controller
| WARNING: not supported pl_clk:
| ERROR: axi_vdma_cam_0: s2mm_introut port is not connected
| ERROR: [Hsi 55-1545] Problem running tcl command ::sw_axi_vdma::generate : ERROR: axi_vdma_cam_0: s2mm_introut port is not connected
| while executing
| "error "ERROR: ${drv_handle}: s2mm_introut port is not connected""

....


Thank you

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
279 Views
Registered: ‎12-04-2016

Re: How to disable device tree generation?

Jump to solution

Hi @dmitril 

 

Try disabling Device tree Auto config from petalinux-config -> Auto config settings

 

and see if that matches to your requirement

 

Best Regards

Shabbir

2 Replies
Moderator
Moderator
280 Views
Registered: ‎12-04-2016

Re: How to disable device tree generation?

Jump to solution

Hi @dmitril 

 

Try disabling Device tree Auto config from petalinux-config -> Auto config settings

 

and see if that matches to your requirement

 

Best Regards

Shabbir

Highlighted
Observer dmitril
Observer
268 Views
Registered: ‎01-17-2018

Re: How to disable device tree generation?

Jump to solution

Yes,

changing

CONFIG_SUBSYSTEM_AUTOCONFIG_DEVICE__TREE=y

to

# CONFIG_SUBSYSTEM_AUTOCONFIG_DEVICE__TREE is not set

seem to work

Thank you

0 Kudos