UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer ishahak
Observer
516 Views
Registered: ‎01-31-2018

How to get rid of "spidev spi1.0: buggy DT: spidev listed directly in DT"

Jump to solution

Hi,

I'm using the UltraZed SOM. Having a kind of "cosmetic" question please.

 

I'm having 3 SPI devices which I modify like this in system-user.dtsi:

 

&spi0{
   #address-cells=<1>;
   #size-cells=<0>;
   status = "okay";

   spidev@0{
      compatible="spidev";
      reg =<0>; //chipselect 0
      spi-max-frequency= <3125000>;
   };
   spidev@1{
      compatible="spidev";
      reg =<1>; //chipselect 1
      spi-max-frequency= <3125000>;
   };
   spidev@2{
      compatible="spidev";
      reg =<2>; //chipselect 2
      spi-max-frequency= <3125000>;
   };

This works fine, but each of the 3 is producing a 66-lines complained while booting, starting with "spidev spi1.0: buggy DT: spidev listed directly in DT".

 

Reading here, I have learned that it is a new change, described as follows:

The commit message reads:

    spi: spidev: Warn loudly if instantiated from DT as "spidev"

    Since spidev is a detail of how Linux controls a device rather than a
    description of the hardware in the system we should never have a node
    described as "spidev" in DT, any SPI device could be a spidev so this
    is just not a useful description.

    In order to help prevent users from writing such device trees generate a
    warning if spidev is instantiated as a DT node without an ID in the match
    table.

    Signed-off-by: Mark Brown <broonie@kernel.org>

 

So my question is: 

What is the "right way" to include SPI devices in a way that will not lead the kernel to complain?

 

EDIT - added this:

 

Is there a way to modify this line:

compatible="spidev";

so that the kernel will not complain, and still the spidev assignment will keep working as it is now?

 

Thanks!

-Itay

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
Observer ishahak
Observer
479 Views
Registered: ‎01-31-2018

Re: How to get rid of "spidev spi1.0: buggy DT: spidev listed directly in DT"

Jump to solution

Solved my own problem by looking here.

I was adapting their "quick and dirty" solution.

 

Setting the compatibility like this:

comptabile = "rohm,dh2228fv"; /* Same as "spidev" but without errors at boot. Search "buggy DT" to understand */

did successfully eliminate the annoying warnings.

0 Kudos
1 Reply
Observer ishahak
Observer
480 Views
Registered: ‎01-31-2018

Re: How to get rid of "spidev spi1.0: buggy DT: spidev listed directly in DT"

Jump to solution

Solved my own problem by looking here.

I was adapting their "quick and dirty" solution.

 

Setting the compatibility like this:

comptabile = "rohm,dh2228fv"; /* Same as "spidev" but without errors at boot. Search "buggy DT" to understand */

did successfully eliminate the annoying warnings.

0 Kudos