UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
690 Views
Registered: ‎02-09-2017

How to let zynq linux boot in root mode?

I am using zynq new uramdisk.image.gz I have found when the linux start up, it is not in root mode. I have to type root to login the root mode.

Could someone tell me how to skip the login step and let linux boot in root mode? Just like the old uramdisk.image.gz.

Thanks very much.

 

New uramdisk.image.gz boot

捕获.JPG

 

捕获2.JPG

 

The old uramdisk.image.gz

 

捕获3.JPG

 

 

The inittab in ramdisk is:

 

 

Inittab
# /etc/inittab: init(8) configuration.
# $Id: inittab,v 1.91 2002/01/25 13:35:21 miquels Exp $

# The default runlevel.
id:5:initdefault:

# Boot-time system configuration/initialization script.
# This is run first except when booting in emergency (-b) mode.
si::sysinit:/etc/init.d/rcS

# What to do in single-user mode.
~~:S:wait:/sbin/sulogin

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin
PS0:12345:respawn:/bin/start_getty 115200 ttyPS0
# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
#  <id>:<runlevels>:<action>:<process>
#

1:12345:respawn:/sbin/getty 38400 tty1

 

How to change it? Thanks very much. 

 

0 Kudos
1 Reply
Voyager
Voyager
655 Views
Registered: ‎06-24-2013

Re: How to let zynq linux boot in root mode?

Hey @felven,

 

What are the kernel options you're passing to the boot?

(you can check that with 'cat /proc/cmdline' from the Linux login)

 

Thanks,

Herbert

-------------- Yes, I do this for fun!
0 Kudos