UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
6,270 Views
Registered: ‎08-20-2014

How to make Xilinx SDK under Ubuntu detect both USB cables?

We successfully installed vivado 2015.1 on Ubuntu14.04.

As for the driver of the cables,  we ran the scripts provided in vivado installation folder.

 

However, when we are trying to repeat the simple hello world experiment (successful when using Windows 7), the terminal of SDK won't provide us with options like COM1...COM4 or even ttyS0...ttyS4.

 

Does anyone know what might be the problem?

0 Kudos
1 Reply
Adventurer
Adventurer
6,253 Views
Registered: ‎08-20-2014

回复: How to make Xilinx SDK under Ubuntu detect both USB cables?

I remember in Windows7, there will be port options like COM1~COM4 in the terminal settings.

But in Ubuntu, there is not any option for the serial port in the terminal settings.

 

Therefore, we installed a 3rd party terminal called Gtkterm, and connect it to /dev/ttyUSB0 and successfully obtained the result "hello world" from this Gtkterm terminal. Then I tried to manually enter "ttyUSB0" or "/dev/ttyUSB0" in the terminal settings of Xilinx SDK, but it keeps telling that:  no such port "ttyUSB0"

 

I was still wondering why this simple experiment does not work on the built-in terminal in SDK... anybody came accross the same problem? 

0 Kudos