UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer zosvitta
Observer
325 Views
Registered: ‎11-02-2018

Issue with upgrading to petalinux 2018.3

Hi,

I am trying to upgrade my codebase running on petalinux 2017.2 to latest 2018.3.

My code base involves displayport application.

I have generated the .sysdef and .bit files using 2018.3 vivado sdk and used in petalinux build.

My /project-spec/meta-user/recipes-bsp/device-tree/files/system-user.dtsi contains entries corresponding to displayport as shown below,

&xilinx_drm {
    status = "okay";
    clocks = <&idt5901>;
    xlnx,vid-clk-pl;
    planes {
        xlnx,pixel-format = "argb8888";
    };
};

&xlnx_dp {
    status = "okay";
    phy-names = "dp-phy0", "dp-phy1";
    phys = <&lane3 PHY_TYPE_DP 0 3 27000000>, <&lane2 PHY_TYPE_DP 1 3 27000000>;
};

&xlnx_dp_sub {
    status = "okay";
    xlnx,vid-clk-pl;
    xlnx,gfx-fmt = "argb8888";
};

&xlnx_dp_snd_card {
    status = "okay";
};

&xlnx_dp_snd_codec0 {
    status = "okay";
};

&xlnx_dp_snd_pcm0 {
    status = "okay";
};

&xlnx_dp_snd_pcm1 {
    status = "okay";
};

 

But during the build, I get errors as

| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:156.1-12 Label or path xilinx_drm not found
| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:165.1-9 Label or path xlnx_dp not found
| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:171.1-13 Label or path xlnx_dp_sub not found
| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:177.1-18 Label or path xlnx_dp_snd_card not found
| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:181.1-20 Label or path xlnx_dp_snd_codec0 not found
| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:185.1-18 Label or path xlnx_dp_snd_pcm0 not found
| Error: /build/tmp/work/plnx_zynqmp-xilinx-linux/device-tree/xilinx+gitAUTOINC+b7466bbeee-r0/system-user.dtsi:189.1-18 Label or path xlnx_dp_snd_pcm1 not found

 

Could you please help me with the reason behind this issue and how can I fix it?

Thanks alot in advance.

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
248 Views
Registered: ‎09-04-2012

Re: Issue with upgrading to petalinux 2018.3

Make sure that the labels that you are referencing in your dtsi (for example xilinx_drm) exist in the auto generated dts and dtsi files.

They should be located here:

<plnx-proj-root>/components/plnx_workspace/device-tree/device-tree/

The label names could be different or not created.

Regards,

Christophe

0 Kudos
Observer zosvitta
Observer
170 Views
Registered: ‎11-02-2018

Re: Issue with upgrading to petalinux 2018.3

Hi,

Thankyou for your reply.

 

I have modified the dtsi file as below.

/*
&xilinx_drm {
    status = "okay";
    clocks = <&idt5901>;
    xlnx,vid-clk-pl;
    planes {
        xlnx,pixel-format = "argb8888";
    };
};

&xlnx_dp {
    status = "okay";
    phy-names = "dp-phy0", "dp-phy1";
    phys = <&lane3 PHY_TYPE_DP 0 3 27000000>, <&lane2 PHY_TYPE_DP 1 3 27000000>;
};

&xlnx_dp_sub {
    status = "okay";
    xlnx,vid-clk-pl;
    xlnx,gfx-fmt = "argb8888";
};

&xlnx_dp_snd_card {
    status = "okay";
};

&xlnx_dp_snd_codec0 {
    status = "okay";
};

&xlnx_dp_snd_pcm0 {
    status = "okay";
};

&xlnx_dp_snd_pcm1 {
    status = "okay";
};
*/

&zynqmp_dpsub {
    status = "okay";
    clocks = <&idt5901>;
    phy-names = "dp-phy0", "dp-phy1";
    phys = <&lane3 PHY_TYPE_DP 0 3 27000000>, <&lane2 PHY_TYPE_DP 1 3 27000000>;
};

&xlnx_dpdma {
    status = "okay";
};

 

Since in the new 4.14 kernal from xilinx the displayport device tree has been modified (Reference: https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842105/ZynqMP+DisplayPort+Linux+driver)

 

Build passes. But my uboot does not recognize the kernal image.

Wrong Image Format for bootm command
ERROR: can't get kernel image!
ZynqMP>

 

I notice that my image.ub is 27.5MB,  where as Image is 79.6MB, system.dtb is 35kB and rootfs.jffs2 is 27.5MB.

So I think that kernel image (Image) is not included in image.ub.

Is it causing the problem with uboot?

How can I fix it?

 

Thanks a lot.

 

 

0 Kudos