cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
3,792 Views
Registered: ‎06-09-2014

JTAG linux boot hangs on ZedBoard

Jump to solution

Hello,

We have a rev D ZedBoard and v2014.1 of the Xilinx tools.  I am working my way through the tutorials in zedboard_CTT_v2013_2_130807.pdf from zedboard_CTT_v2013_2_130807.zip.  Because it is for v2013.2 there have been a number of issues I've had to get around, but I'm stuck on this one.

In chapter 5 "Booting Linux and Application Debugging Using SDK", I got as far as beginning the linux boot (5.2.3 step 7).  Some time into the boot the ZedBoard hangs, suspiciously after some non-ASCII output.  The terminal output is attached.

When the jumpers are in SD card boot configuration it boots the out-of-the-box linux on the SD card.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
5,007 Views
Registered: ‎06-09-2014

Thanks for the suggestions folks.

 

It seems it's a problem with the CTT document.  An earlier tutorial turned off just about everything in the processor core but there were no steps saying to turn the ethernet and USB back on.  The answer can be found from back in February in http://www.zedboard.org/content/problem-chapter-5-zedboardctt-tutorial.  The document hasn't been updated to fix this since.

View solution in original post

0 Kudos
3 Replies
Highlighted
Xilinx Employee
Xilinx Employee
3,782 Views
Registered: ‎08-01-2008
Seen this issue earlier on Ubuntu. Migrating to CentOS resolved the issue.
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
3,768 Views
Registered: ‎03-13-2012

The flow you're following seems to be really old and - at least partly - deprecated.

You could try to figure out the JTAG boot flow using these binaries from the Xilinx wiki: http://www.wiki.xilinx.com/Zynq+Releases . Those should work for booting your board. The documentation you use will probably not fully work for those. E.g. booting Linux using 'go' has been deprecated quite a while back and you'd have to migrate to use 'bootm', but apart from such details things may work when you just swap out the binaries.

0 Kudos
Highlighted
Contributor
Contributor
5,008 Views
Registered: ‎06-09-2014

Thanks for the suggestions folks.

 

It seems it's a problem with the CTT document.  An earlier tutorial turned off just about everything in the processor core but there were no steps saying to turn the ethernet and USB back on.  The answer can be found from back in February in http://www.zedboard.org/content/problem-chapter-5-zedboardctt-tutorial.  The document hasn't been updated to fix this since.

View solution in original post

0 Kudos