cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
2,246 Views
Registered: ‎08-09-2017

Kernel Hacking

Jump to solution

I'm trying to modify the kernel config (using make menuconfig) and I cant seem to disable kernel debugging. It appears to have dashes between it and cant be modified.

 

doing a grep, I also see this:

include/generated/autoconf.h:#define CONFIG_DEBUG_KERNEL 1

 

I'm not sure how CONFIG_DEBUG_KERNEL is set here and how this file is generated. Any guidance would be appreciated!

Tags (2)
kernel_hacking.JPG
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Voyager
Voyager
3,474 Views
Registered: ‎06-24-2013

Hey @jms528

 

The _*_ means that something actively requires (i.e. selects) this option.

 

If you move over the option and press '?' you will get detailed information about it, like this:

 Say Y here if you are developing drivers or trying to debug and  
 identify kernel problems.					  
								  
 Symbol: DEBUG_KERNEL [=y]					  
 Type  : boolean						  
 Prompt: Kernel debugging					  
   Location:							  
     -> Kernel hacking  					  
   Defined at lib/Kconfig.debug:385				  
   Selected by: EXPERT [=y]			    

Hope this clarifies,

Herbert

-------------- Yes, I do this for fun!

View solution in original post

0 Kudos
3 Replies
Highlighted
Voyager
Voyager
3,475 Views
Registered: ‎06-24-2013

Hey @jms528

 

The _*_ means that something actively requires (i.e. selects) this option.

 

If you move over the option and press '?' you will get detailed information about it, like this:

 Say Y here if you are developing drivers or trying to debug and  
 identify kernel problems.					  
								  
 Symbol: DEBUG_KERNEL [=y]					  
 Type  : boolean						  
 Prompt: Kernel debugging					  
   Location:							  
     -> Kernel hacking  					  
   Defined at lib/Kconfig.debug:385				  
   Selected by: EXPERT [=y]			    

Hope this clarifies,

Herbert

-------------- Yes, I do this for fun!

View solution in original post

0 Kudos
Highlighted
Visitor
Visitor
2,115 Views
Registered: ‎08-09-2017

Hi Herbert,

 

Thanks for your response! The "?" was something I was unaware of. I was able to trace it back to being enabled by default when EXPERT was selected (which it was since EMBEDDED was also turned on). After commenting out the line in the Kbuild, I was able to turn it off. Thanks for the help!

0 Kudos
Highlighted
Voyager
Voyager
2,109 Views
Registered: ‎06-24-2013

You're welcome!

 

Best,

Herbert

-------------- Yes, I do this for fun!
0 Kudos