UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
1,448 Views
Registered: ‎07-06-2017

Kernel module changed to autoload between 2016.4 and 2017.1

I have been using Petalinux 2016.4 to develop and debug a custom kernel module for Ultrascale.

It was added to the rootfs with:

petalinux-create -t modules --name <user-module-name> --enable

This module showed up in the rootfs but did not load at Linux start-up.

 

After updating to petalinux 2017.1, it is being loaded on Linux boot. I can however find no entry in /etc for module loading (/etc/modules or similar).

 

This is an out-of-tree module, found in /lib/modules/<uname>/extra/.

 

Anyone that can help with disabling this behavior? As it is, the module is done and only need to update a firmware it uses, I would like to not need to rebuild it all just to copy over a binary file.

0 Kudos