cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
lowerbound
Visitor
Visitor
3,779 Views
Registered: ‎06-25-2017

Keyboard Issue about Ubuntu Desktop on ZCU102 Rev.1

Hi everybody,

 

I've recently tried to run Ubuntu Desktop on ZCU102 Rev.1 in the following post:

http://www.wiki.xilinx.com/Zynq+UltraScale%EF%BC%8B+MPSoC+Ubuntu+part+2+-+Building+and+Running+the+Ubuntu+Desktop+From+Sources

 

All is well, and Ubuntu is perfectly running. I can see the GUI of Ubuntu on my monitor through DP port.

However, when I used a USB hub to connect my keyboard to ZCU board, the keyboard did not work. (NumLock is off. Therefore I suspect there is no power for the keyboard. USB mouse did not work either.)

USB hub and keyboard wire are all USB 2.0.

 

Did anyone encounter such a problem? I cannot figure out now ...

 

Regards,

0 Kudos
5 Replies
hbucher
Scholar
Scholar
3,751 Views
Registered: ‎03-22-2016

@lowerbound going on a limb here - doesnt usb need to be entered manually in the device tree?

 

vitorian.com --- We do this for fun. Always give kudos. Accept as solution if your question was answered.
I will not answer to personal messages - use the forums instead.
0 Kudos
florentw
Moderator
Moderator
3,723 Views
Registered: ‎11-09-2015

HI @lowerbound,

 

Could you try without the hub? I think you need to use the 2 usb ports for the keyboard and the mouse. I am not sure if usb hubs are supported with this application.

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos
andrea_2202
Observer
Observer
3,308 Views
Registered: ‎05-29-2017

Hi all,

I've exactly the same problem.

Qith the older version fo the board(preproduction) compiled with petalinux 2016.4 all worked fine.

Now I'm able to complete the boot of ubuntu but the USB3 doesn't work with any device.

 

Any solution?

0 Kudos
andrea_2202
Observer
Observer
3,197 Views
Registered: ‎05-29-2017

Hi @lowerbound,

I've found the solution.

Chech the jumper near the USB connector.

In particular the J7 jumper must be plugged in for the usb to work! (See the photo for the correct jumper configuration)

 

Regards

j7.jpg
elilau
Visitor
Visitor
1,312 Views
Registered: ‎02-17-2019

Hi Andrea

Just followed yours USB instruction and its worked perfect for me on my zcu-102 EVB.
Could get the USB HUB, KB & Mouse detected and working.
Thx Eli

0 Kudos