UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
1,878 Views
Registered: ‎08-01-2017

Linux Application Running but not getting Desired Output

I am following ug1165 to flow leds using custom IP core, previously I was not able to run the linux application now I cross compiled it successfully and Linux App is running but when I press 1 or 0 then I get "Kernel Print" kind of thing instead of blinking Leds.

 

note: FPGA program loading is also successful.

 

 

 

 

 

kernel_error_sc.png
linux_app_blink_dev.png
linux_app_error_sc.png
linux_app_error_sc2.png
0 Kudos
2 Replies
Explorer
Explorer
1,837 Views
Registered: ‎04-05-2016

Re: Linux Application Running but not getting Desired Output

I'm not sure if I understand what question you are asking here. Can you provide some additional information on what you are looking to do?
0 Kudos
Adventurer
Adventurer
1,827 Views
Registered: ‎08-01-2017

Re: Linux Application Running but not getting Desired Output

I am trying to glow PL side LEDs using linux application which is explained in UG1165, I completed all the steps and even that linux application is running as you can see in Screen shot I sent, but it gets terminated when I select 1 or 0, it prints Kernel Print : set ( when 1 is pressed ) Kernel print : reset (when I select 0 ).

 

My problem is that I am unable to debug it and trace issue and where the thing is going wrong. What needs to be corrected? Where should I look into?

 

note: I have implemented chapter-9 "Custom IP and Device Driver for Linux " and I am using my own created block design in vivado 2016.3 as per instruction given in the ug1165 but I am using those files which is provided in UG1165.

 

0 Kudos