cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
brasilino
Adventurer
Adventurer
640 Views
Registered: ‎08-07-2014

Making Petalinux/Yocto build deb packages instead of rpms

Jump to solution

Hello All,

By default, Petalinux builds rpms of software packages that goes into rootfs. I'm trying to make it build deb packages.

The Yocto's PACKAGE_CLASSES variable is used for this purpose: https://www.yoctoproject.org/docs/1.8/ref-manual/ref-manual.html#var-PACKAGE_CLASSES

 

I've set in the "build/conf/local.conf" file this variable as:

PACKAGE_CLASSES ?= "package_deb"

However, rpms are still being built. What am I missing ?

 

Thanks!

Brasilino

0 Kudos
1 Solution

Accepted Solutions
wkulp
Visitor
Visitor
525 Views
Registered: ‎02-04-2014

The ?= syntax only sets a variable if it has not yet been set.  Try replacing it with

PACKAGE_CLASSES = "package_deb"

View solution in original post

4 Replies
aravindb
Moderator
Moderator
598 Views
Registered: ‎02-07-2018

Hi @brasilino 

 

Please add this below line if you dont want to build any type of extension as a part of build.

By default it will generate(build) all types of extensions.

For your reference i have added below many types of extensions. But in your case , just add only rpm.

 

vim project-spec/meta-user/conf/petalinuxbsp.conf

IMAGE_FSTYPES_remove = " tar.gz rpm cpio cpio.gz.u-boot"

 

 

Thanks & Regards

Aravind

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

0 Kudos
brasilino
Adventurer
Adventurer
569 Views
Registered: ‎08-07-2014

@aravindb 

 

Thanks, however it didn't work. BTW, I'm using Petalinux 2019.2.

I've edited "project-spec/meta-user/conf/petalinuxbsp.conf" and added rpm:

IMAGE_FSTYPES_remove = "wic.qemu-sd rpm"

Then edited "build/conf/local.conf" setting to deb packages being built:

PACKAGE_CLASSES ?= "package_deb"

That had no effect. RPM packages still being built, while no deb were at all.

 

Any other thoughts?

 

Thanks

Brasilino

0 Kudos
wkulp
Visitor
Visitor
526 Views
Registered: ‎02-04-2014

The ?= syntax only sets a variable if it has not yet been set.  Try replacing it with

PACKAGE_CLASSES = "package_deb"

View solution in original post

brasilino
Adventurer
Adventurer
511 Views
Registered: ‎08-07-2014

Hello @wkulp 

 

Fantastic! With your tip I looked on bitbake docs and found this info: https://www.yoctoproject.org/docs/1.6/bitbake-user-manual/bitbake-user-manual.html#setting-a-default-value

Also, I decided to configure petalinux's "user" layer, so I added the:

PACKAGE_CLASSES = "package_deb"

to the "project-spec/meta-user/conf/petalinuxbsp.conf" file instead of "build/conf/local.conf". It worked!

 

Thanks a lot,

Regards

Brasilino

0 Kudos