UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
6,978 Views
Registered: ‎07-17-2008

Microblaze and BlueCat GPL

Jump to solution

I am trying to use the GPL version of BluCat linux.

After lots of efforts, I am able to see it in the OS list of EDK under Software Platform Setting.

Now when I am trying to compile and generate lib, I am getting the following error.

 

/*==============================*/

ERROR:MDT - linux_bc54 () - uname: invalid option -- o
   Try `uname --help' for more information.
       while executing
   "exec bash -c "uname -o""
       (procedure "fix_path_cygwin" line 2)
       invoked from within
   "fix_path_cygwin $target_dir"
       (procedure "::sw_linux_bc54_v1_00_a::linux_drc" line 27)
       invoked from within
   "::sw_linux_bc54_v1_00_a::linux_drc 60294256"
ERROR:MDT - Error while running DRC for processor microblaze_0...
make: *** [microblaze_0/lib/libxil.a] Error 2

/*==========================================*/

 

Can anybody suggest what has gone wrong or may be I should upgrade to the new cygwin version.

I am using EDK 10.1 for my experiment.  I will be using the Spartan 3E 500 for my design, but I guess, that should not be a problem.

Thanks

0 Kudos
1 Solution

Accepted Solutions
Visitor bluehorn
Visitor
7,929 Views
Registered: ‎08-14-2007

Re: Microblaze and BlueCat GPL

Jump to solution
The error message you quote is about some Tcl script in EDK trying to run the command "uname -o".

On my system (Debian unstable), this gives the following output:

torsten@sharokan:~$ uname -o
GNU/Linux

According to the uname documentation (available usually via "info coreutils uname"), "-o" ask uname to print the name of the operating system. I am not sure if that option is a new one, I have never seen it in use before.

You may need to upgrade coreutils (my version is 6.10-6).
0 Kudos
2 Replies
Visitor bluehorn
Visitor
7,930 Views
Registered: ‎08-14-2007

Re: Microblaze and BlueCat GPL

Jump to solution
The error message you quote is about some Tcl script in EDK trying to run the command "uname -o".

On my system (Debian unstable), this gives the following output:

torsten@sharokan:~$ uname -o
GNU/Linux

According to the uname documentation (available usually via "info coreutils uname"), "-o" ask uname to print the name of the operating system. I am not sure if that option is a new one, I have never seen it in use before.

You may need to upgrade coreutils (my version is 6.10-6).
0 Kudos
6,959 Views
Registered: ‎07-17-2008

Re: Microblaze and BlueCat GPL

Jump to solution

Thanks.

My problem is now solved after upgrading the coreutils.

0 Kudos