UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor azov3902
Visitor
7,010 Views
Registered: ‎09-08-2015

Missing header files in /usr/src/linux/include

Hi all,

 

I'm attempting to use DMA from user space in Linux running on the processor of the Zynq.

I'm using Linaro Ubuntu version 4.7.3-12 and kernel version 4.0.0. I have a test application ready to go, but it requires the following include files:

#include <linux/dmaengine.h>

#include <linux/dma-mapping.h>

#include <linux/slab.h>

I have double- and triple-checked that I've configured the kernel correctly using the graphical kernel configuration tool to make these modules be included in the build, but they do not show up on boot - my /usr/include/linux directory does not contain any of these files. 

 

I have tried to install the header files manually (apt-get install linux-headers-3.4.0-1486) but I have no idea which package to choose for the Zynq - I'm using kernel version 4.0.0 but the most recent one in the repo that supports ARM is 3.4.0. I tried installing that, but my code won't compile because of errors in the header files which must mean that there's some discrepancy between the header files of the two kernel versions or something like that. 

 

So basically I want to know why the header files won't show up even though I've configured the kernel to include them, and how I might go about fixing it. I'm really new to all of this and I have no idea what to do. Any help would be greatly appreciated. 

0 Kudos
2 Replies
Observer naveeng
Observer
6,564 Views
Registered: ‎11-25-2015

Re: Missing header files in /usr/src/linux/include

Hi,

 

Please also try using linux/version.h if not. This will resolve comapatibility issues from one kernel version to another.

 

Thanks,

Naveen

0 Kudos
Visitor divcesar
Visitor
1,464 Views
Registered: ‎07-11-2017

Re: Missing header files in /usr/src/linux/include

Same problem here.

 

I flashed a pre-built image of Ubuntu with a xilinx-4.6 kernel but now I need the headers to compile+load a driver but can't find them anywhere. Any idea where I might get that?

0 Kudos