UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor atpjpta
Visitor
7,554 Views
Registered: ‎02-15-2015

Need 2015.4 Zybo .bsp file for PetaLinux Workshop

Hello!

 

I am trying to complete the petalinux workshops found here:

 

http://www.xilinx.com/support/university/vivado/vivado-workshops/Vivado-embedded-linux-zynq.html#

 

I've installed PetaLinux SDK 2015.4 and gotten to lab 2, at which point I run into a problem. The lab references a file called "ZYBO_petalinux_v2014_2.bsp" on page 2 (step 1-2-1) which does not work for 2015.4's petalinux-build command (used in step 2-1-1). Initially, the petalinux-build command issues a warning:

 

"WARNING: Your PetaLinux project was last modified by PetaLinux SDK version "2014.2",
WARNING: however, you are using PetaLinux SDK version "2015.4"."

 

It then asks if you would like to continue anyways. After saying yes, it attempts to build the image but immediately fails with the error message:

 

"INFO: Checking component...
ERROR: Cannot find XLNX__3___14 of linux-kernel
INFO: Generating make files and build linux
INFO: Generating make files for the subcomponents of linux
ERROR: Cannot find XLNX__3___14 of linux-kernel
ERROR: Failed to get subcomponents for linux
ERROR: Failed to build linux! Failed to get makefiles for subcomponents of linux!"

 

How can I resolve this? Or, is there a "ZYBO_petalinux_v2015_4.bsp" available anywhere that I can use to complete these tutorials?

 

Thank you!

0 Kudos
4 Replies
7,498 Views
Registered: ‎09-28-2015

Re: Need 2015.4 Zybo .bsp file for PetaLinux Workshop

I am having the same exact problem. Is there no Zybo board support package ".bsp" for the 2015.4 toolchain?

0 Kudos
Visitor jkoller
Visitor
7,078 Views
Registered: ‎10-08-2015

Re: Need 2015.4 Zybo .bsp file for PetaLinux Workshop

Where did the .bsp you have come from?  I've downloaded all files and do not have any lab2 folders, nor any sources for ZYBO_petalinux_*.bsp

 

 

0 Kudos
Visitor jkoller
Visitor
7,072 Views
Registered: ‎10-08-2015

Re: Need 2015.4 Zybo .bsp file for PetaLinux Workshop

I found it in the LiveUSB .zip. I already have a linux install, so never went through that documentation.
0 Kudos
Scholar sampatd
Scholar
7,011 Views
Registered: ‎09-05-2011

Re: Need 2015.4 Zybo .bsp file for PetaLinux Workshop

The problem is that PetaLinux 2015.4 expects 4.0 kernel whereas PetaLinux 2014.2 uses 3.14 version of kernel

To use 3.14 kernel with PetaLinux 2015.4 tool, check if the following AR helps:
http://www.xilinx.com/support/answers/55977.html
0 Kudos