UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
3,651 Views
Registered: ‎11-30-2015

Network Interface file Petalinux 2017.1

Jump to solution

Hi!

 

In my application I need to set Ethernet IP address, so how to change interface file in /etc/network/ ?

In Petalinux 2016.4 it was possible to do it by putting an init-ifupdown folder (with bbappend and interface files in it) in recipes-core, but now I have that warning during petalinux-build:

 

WARNING: The init-ifupdown:do_fetch sig is computed to be 9671e7c4bf8d4e1a44c5a67f6fc60442, but the sig is locked to 9a10549c7af85144d164d9728e8fe23f in SIGGEN_LOCKEDSIGS_t-cortexa9hf-neon

 

After, checking, I see that interface file is still the default one in the embedded linux.

File wich can be find in Petalinux 2017.1 install director:

(install path petalinux-v2017.1-final)/components/yocto/source/arm/layers/core/meta/recipes-core/init-ifupdown/init-ifupdown-1.0/interfaces

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
6,275 Views
Registered: ‎11-09-2015

Re: Network Interface file Petalinux 2017.1

Jump to solution

hi,

   you may setting the wrong ethernet phy address,try set it to 0 at your devicetree.(other part of the devicetree may different from your‘s,it's just an example)

eg:

                phy@0 {
                compatible = "marvell,88e1510";
                device_type = "ethernet-phy";
                reg = <0x0>;   // phy addr
                marvell,reg-init = <0x3 0x10 0xff00 0x1e 0x3 0x11 0xfff0 0xa>;
            };

BRs,

0 Kudos
3 Replies
Adventurer
Adventurer
3,618 Views
Registered: ‎11-30-2015

Re: Network Interface file Petalinux 2017.1

Jump to solution

In fact Network do not work at all in my configuration with a Zynq MMP board (with petalinux 2016.4, i don't have that issue).

There's a wrong address for the Phy and it can not be detected by the Ethernet MAC.

The messages at the beginning of the u-boot process show the issue

 

If someone from Xilinx have an idea.

 

Thank you.

 

0 Kudos
Highlighted
Explorer
Explorer
6,276 Views
Registered: ‎11-09-2015

Re: Network Interface file Petalinux 2017.1

Jump to solution

hi,

   you may setting the wrong ethernet phy address,try set it to 0 at your devicetree.(other part of the devicetree may different from your‘s,it's just an example)

eg:

                phy@0 {
                compatible = "marvell,88e1510";
                device_type = "ethernet-phy";
                reg = <0x0>;   // phy addr
                marvell,reg-init = <0x3 0x10 0xff00 0x1e 0x3 0x11 0xfff0 0xa>;
            };

BRs,

0 Kudos
Adventurer
Adventurer
3,559 Views
Registered: ‎11-30-2015

Re: Network Interface file Petalinux 2017.1

Jump to solution

Hi

 

 

 

Thanks again.

0 Kudos