cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
eloff
Visitor
Visitor
7,060 Views
Registered: ‎10-07-2015

No ethernet connectivity with Petalinux 2015.2.1 on Zync zc706

Jump to solution

After upgrading from Petalinux 2014.4 to 2015.2.1 there is no ethernet connectivity.

 

There are some ethernet related changes in the update, for example the driver has changed to macb.

 

I have the following in my system-top.dts:

&gem0 {
	status = "okay";
	phy-mode = "rgmii-id";
	phy-handle = <&ethernet_phy>;

	ethernet_phy: ethernet-phy@7 {
		compatible="marvell,88e1116r";
		device_type="ethernet-phy";
		reg = <7>;
	};
};

 

 

// zynq-7000.dtsi
gem0: ethernet@e000b000 { compatible = "cdns,gem"; reg = <0xe000b000 0x1000>; status = "disabled"; interrupts = <0 22 4>; clocks = <&clkc 30>, <&clkc 30>, <&clkc 13>; clock-names = "pclk", "hclk", "tx_clk"; #address-cells = <1>; #size-cells = <0>; };

 

Linux is able to find the eth0 interface and I can configure it with static ip. However, it is not possible to ping, in either direction.

 

LED0 on the board blinks when trying to ping from PC. There is no activity when trying to ping from petalinux.

 

Any idea how to get the ethernet working?

 

Related links:

http://www.xilinx.com/support/answers/65282.html (PetaLinux 2015.2 - Device Tree Does Not Load The Proper Drivers for USB or Ethernet, should be solved in 2015.2.1)

http://www.xilinx.com/support/answers/61117.html (PetaLinux - My System Device Tree DTS Does Not Include Ethernet PHY Information)

https://forums.xilinx.com/t5/Embedded-Linux/xemacps-e000b000-ps7-ethernet-eth0-no-PHY-setup/td-p/499018 (xemacps e000b000.ps7-ethernet: eth0: no PHY setup)

0 Kudos
1 Solution

Accepted Solutions
eloff
Visitor
Visitor
13,277 Views
Registered: ‎10-07-2015

It turned out that, for some reason, mdio was not enabled for eth0 in my system.hdf. So there was no connection to the actual pins, oops. The FPGA developer fixed this and now ethernet connectivity works again.

View solution in original post

0 Kudos
4 Replies
fanat9
Explorer
Explorer
7,051 Views
Registered: ‎02-16-2014

Try to set Phy reg to 0.

 

phy0: phy@0 {
	#address-cells = <1>;
	#size-cells = <0>;
	compatible = "marvell,88e1116r";
	device_type = "ethernet-phy";
	reg = <0>;
};

 

0 Kudos
linnj
Xilinx Employee
Xilinx Employee
7,031 Views
Registered: ‎09-10-2008

Hi,

 

I've not tried it myself but here's how I'd go about figuring it out.  I tend to look at the device tree for the release on github that is used for the Linux kernel independent of Petalinux.

 

https://github.com/Xilinx/linux-xlnx/blob/xilinx-v2015.2.03/arch/arm/boot/dts/zynq-zc706.dts

 

This is what is shows for they phy (it pasted in wierd).

 

I can't see why you would want to change the PHY address, but maybe I'm missing sommething there. That should be hard wired on the board and should never change.

 

Thanks

John

 

 

  &gem0 {
  status = "okay";
  phy-mode = "rgmii-id";
  phy-handle = <&ethernet_phy>;
   
  ethernet_phy: ethernet-phy@7 {
  reg = <7>;
  };
  };
0 Kudos
linnj
Xilinx Employee
Xilinx Employee
7,028 Views
Registered: ‎09-10-2008

http://www.xilinx.com/support/answers/65504.html

 

And I forgot about this answer record also.

0 Kudos
eloff
Visitor
Visitor
13,278 Views
Registered: ‎10-07-2015

It turned out that, for some reason, mdio was not enabled for eth0 in my system.hdf. So there was no connection to the actual pins, oops. The FPGA developer fixed this and now ethernet connectivity works again.

View solution in original post

0 Kudos